Closed Bug 644645 Opened 9 years ago Closed 9 years ago

Error on startup: "ASSERT: gBrowser.addProgressListener was called with a second argument", w/ Greasemonkey, NoScript, Stylish, or XMarks

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: ogreger, Assigned: Gavin)

References

Details

(Keywords: assertion)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.2a1pre) Gecko/20110324 Firefox/4.2a1pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.2a1pre) Gecko/20110324 Firefox/4.2a1pre

Full error message follows:
ASSERT: gBrowser.addProgressListener was called with a second argument, which is not supported.  See bug 608628.
Stack Trace:
0:addProgressListener([object Object],136)
1:()
2:([object Event])

I did look up the bug 608628 and the entry I found did not seem to be describing the same problem, thus the separate entry.


Reproducible: Always

Steps to Reproduce:
1. simply run the program.
2. error as stated above occurs.
3. Click on OK, program opens as usual.

This is new.  I have not had this occur before today.
I'm seeing this as well. Hasn't appeared before the 3/24 nightly build.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → Trunk
Click on an image at Amazon to zoom and you see it as well, ie http://www.amazon.com/gp/product/B0033ZHIJU click on the vitamin bottle.
(In reply to comment #2)
> Click on an image at Amazon to zoom and you see it as well, ie
> http://www.amazon.com/gp/product/B0033ZHIJU click on the vitamin bottle.

Ah, it's a bug with window creation, you can duplicate it by selecting File, new window.
If I disable the extensions Stylish and Greasemonkey, this issue goes away. Some other extensions that might be causing this are NoScript, Xmarks and Status-4-Evar. I think there might be a full list @ http://forums.mozillazine.org/viewtopic.php?f=23&t=2142293.
Well that makes it simple for the developers then. I am not a programmer :) But clearly if the change to gBrowser.addProgressListener was intentional, then this is not a bug, and all the extensions need to be updated. (Raising additional question, would this cause backward compatibility issues if the second argument was previously required?)
I took the easiest solution first, and it seems to have cured the problem.  I disabled No Script and the problem went away.
Sherry confirmed, disabling Noscript 2.0.9.9. gets rid of the message
Quoting the forums linked in Comment 4 -- looks like the extensions just need patching:
> To 'fix' the assert message what I did was open the XPI for the affected add-on[...]
> search for gBrowser.addProgressListener. Delete the second parameter of the two. Save.
> Example:
> gBrowser.addProgressListener(FasterFox_Lite_BigRedBrent.Listener, Components.interfaces.nsIWebProgress.NOTIFY_STATE_DOCUMENT);
> becomes
> gBrowser.addProgressListener(FasterFox_Lite_BigRedBrent.Listener);
OS: Windows 7 → All
Hardware: x86 → All
Summary: Error on Startup, ASSERT:gBrowser.addProgressListener was called with a second argument → Error on startup: "ASSERT: gBrowser.addProgressListener was called with a second argument", w/ Greasemonkey, NoScript, Stylish, or XMarks
Duplicate of this bug: 644860
Yes, the extensions need fixing. Until then, I don't think we need to assert noisily.
Assignee: nobody → gavin.sharp
Status: NEW → ASSIGNED
http://hg.mozilla.org/mozilla-central/rev/845c60229f3e
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
(In reply to comment #10)
> Yes, the extensions need fixing. Until then, I don't think we need to assert
> noisily.

True, but the Assert pop-up prompted me to update my extensions as soon as I saw it event though it was late and I normally would have left it till morning.
That's fine - it isn't a critical issue.
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: FIXED → ---
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Duplicate of this bug: 645264
Depends on: 684016
You need to log in before you can comment on or make changes to this bug.