Last Comment Bug 644746 - Call updateVisibility when constructing the tabs container rather than when addProgressListener is called for the first time
: Call updateVisibility when constructing the tabs container rather than when a...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 12
Assigned To: Dão Gottwald [:dao]
:
: Dão Gottwald [:dao]
Mentors:
Depends on: 734273 734814
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-24 13:40 PDT by Dão Gottwald [:dao]
Modified: 2012-03-13 08:16 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.93 KB, patch)
2011-03-24 13:40 PDT, Dão Gottwald [:dao]
no flags Details | Diff | Splinter Review
updated to tip (1.98 KB, patch)
2011-05-17 09:05 PDT, Dão Gottwald [:dao]
gavin.sharp: review+
Details | Diff | Splinter Review

Description Dão Gottwald [:dao] 2011-03-24 13:40:37 PDT
Created attachment 521618 [details] [diff] [review]
patch

Simple cleanup, updateVisibility is logically independent from addProgressListener.
Comment 1 Dão Gottwald [:dao] 2011-05-17 09:05:34 PDT
Created attachment 532986 [details] [diff] [review]
updated to tip
Comment 2 Dão Gottwald [:dao] 2011-05-18 23:29:53 PDT
http://hg.mozilla.org/mozilla-central/rev/63284a27cb1b
Comment 3 Dão Gottwald [:dao] 2011-05-19 02:55:51 PDT
Backed out, since browser_bug585785.js is failing intermittently on OS X.
Comment 5 Ed Morley [:emorley] 2012-01-07 19:31:54 PST
https://hg.mozilla.org/mozilla-central/rev/840ffcc76aa3

Note You need to log in before you can comment on or make changes to this bug.