Clean up some bookmarks stuff

VERIFIED FIXED

Status

SeaMonkey
Bookmarks & History
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Blake Ross, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows ME

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

17 years ago
Attaching a patch for some clean-up and a couple bugfixes.
(Assignee)

Comment 1

17 years ago
oops
Assignee: ben → blakeross
(Assignee)

Comment 2

17 years ago
Created attachment 21921 [details] [diff] [review]
[patch] cleanup
(Assignee)

Comment 3

17 years ago
Created attachment 21922 [details] [diff] [review]
[patch] -bw
(Assignee)

Comment 4

17 years ago
This fixes 57191, and an as-yet (I think) unreported bug -- the custom keywords 
option shouldn't be visible in the tree, the menulist or the menu if you're 
searching history.  I did this in a generic enough way that it eventually could 
apply to hiding more items and different search types (e.g. when you want to 
search history for last visited, etc., which you probably wouldn't want to do 
with bookmarks -- i'll file that soon), although we may eventually just bite 
the bullet and split bookmarks and history search into two separate windows.

anyways, cc'ing alec for sr.
Status: NEW → ASSIGNED
(Assignee)

Comment 5

17 years ago
cc'ing timeless for r=, yes I will fix the newline, yes I will fix every 
possible spacing problem on earth...
(Assignee)

Updated

17 years ago
Summary: Cleanup some bookmarks stuff → Clean up some bookmarks stuff

Comment 6

17 years ago
sr=alecf
(Assignee)

Comment 7

17 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.