Closed Bug 644790 Opened 9 years ago Closed 9 years ago

Fennec crash on startup [@ nsCycleCollector::BeginCollection]

Categories

(Firefox for Android Graveyard :: General, defect, critical)

ARM
Android
defect
Not set
critical

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: kbrosnan, Unassigned)

References

Details

Attachments

(1 file)

Attached file crash log
Updated to today's build. Now is crashing on startup. See attached log. Had a crash report submitted but I can't reach it by about:crashes. Where is the profile folder in the android file system?
tracking-fennec: --- → ?
I'm crashing on startup on HTC Evo 4G running Android 2.2 also.  Likewise, I can't get in far enough to run about:crashes, and the debugger's telling me org.mozilla.fennec doesn't exist when I try to look on the filesystem.
Is this on the RC as well? If so, we should add this to the unsupported devices list.
4.0rc1 starts, bit sluggish but that is the phone.
Summary: xperia crash on startup → Fennec crash on startup
Summary: Fennec crash on startup → Fennec crash on startup [@ nsCycleCollector::BeginCollection]
Please back out if it can be done cleanly.

There are two issues with the patches in bug 620931

1. The android code uses -omnijar and bug 620931 does not fix
GeckoAppShell.java which uses it.
2. The code adds an additional assumption that the omnijar is named omni.jar.
This is not at all the case. This assumption should be removed since the
omnijar is the apk on android, and in the future, we could even make the
omnijar the firefox executable itself.
Depends on: 620931
I backed out the entirety of the push that caused this.  The backout is:
http://hg.mozilla.org/mozilla-central/pushloghtml?changeset=e11c2f95f781
This seems to be fixed in today's build, so it looks like the backout was effective.

However, any end-users who (automatically) got yesterday's build now have a non-functional Fennec installation on their device.  It can't start up, so it can't update itself.  That's a pretty bad spot to be in.

Given that it took some bisecting to find out when this broke, I'm assuming this bug didn't turn any tinderboxen orange.  Do we need more automated android testing  infrastructure to catch these sorts of things (startup-crashes blocking any activity) in the future?
(In reply to comment #8)

> Given that it took some bisecting to find out when this broke, I'm assuming
> this bug didn't turn any tinderboxen orange.  Do we need more automated android
> testing  infrastructure to catch these sorts of things (startup-crashes
> blocking any activity) in the future?

The existing tinderbox automation should have caught the problem, but it was purple from unrelated issues.
It would help, though, to have these tests run on try, too. I would have caught the problem before landing. I could have tried the try build on an android device, but at the time I was baking the patch queue, I didn't have one.

Anyways, sorry for the mess, and sorry not to have noticed earlier. It also doesn't help that mobile tbpl is separated.
Duplicate of this bug: 644796
tracking-fennec: ? → ---
Verified fixed on:
Mozilla/5.0 (Android;Linux armv7l;rv:8.0a1)Gecko/20110905
Firefox/8.0a1 Fennec/8.0a1
Device: Samsung Galaxy S
OS: Android 2.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.