Last Comment Bug 644861 - --enable-application should default to browser
: --enable-application should default to browser
Status: RESOLVED FIXED
fixed-in-bs
: dev-doc-complete
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
-- normal (vote)
: mozilla5
Assigned To: Mitchell Field [:Mitch]
:
: Gregory Szorc [:gps] (away until 2017-03-20)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-24 17:43 PDT by Ted Mielczarek [:ted.mielczarek]
Modified: 2011-04-13 09:47 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.24 KB, patch)
2011-03-25 01:08 PDT, Mitchell Field [:Mitch]
ted: review+
Details | Diff | Splinter Review

Description User image Ted Mielczarek [:ted.mielczarek] 2011-03-24 17:43:18 PDT
I mentioned this on IRC and on a mailing list, and got positive responses. We should make --enable-application default to browser, so that simply running "configure && make" from a source tarball gets you a Firefox build that's almost identical to what we ship. This is the only required configure option right now, and since 99% of people want to build Firefox, we might as well just make it easier. This makes us more in line with other open source project builds as well.

(Since client.mk defaults to an objdir, this means you could also make -f client.mk without a mozconfig and get a reasonable build of Firefox in an objdir.)
Comment 1 User image Mitchell Field [:Mitch] 2011-03-25 01:08:36 PDT
Created attachment 521749 [details] [diff] [review]
Patch
Comment 2 User image Ted Mielczarek [:ted.mielczarek] 2011-03-25 05:21:37 PDT
Comment on attachment 521749 [details] [diff] [review]
Patch

Looks good, thanks!
Comment 3 User image Mitchell Field [:Mitch] 2011-03-25 08:00:02 PDT
http://hg.mozilla.org/projects/build-system/rev/cdd24c96c6f4
Comment 4 User image Mitchell Field [:Mitch] 2011-03-28 08:16:42 PDT
http://hg.mozilla.org/mozilla-central/rev/cdd24c96c6f4
Comment 5 User image Eric Shepherd [:sheppy] 2011-04-13 00:13:24 PDT
I've updated:

https://developer.mozilla.org/en/Configuring_Build_Options

This has a note at the top as well as a similar one where it talks about --enable-application.

In addition, I've added information about mozilla-aurora to:

https://developer.mozilla.org/En/Developer_Guide/Source_Code/Mercurial#mozilla-aurora_(second-stage_development_tree)

Figured I'd tackle that at the same time since it's somewhat related.

In addition, this change is mentioned on Firefox 5 for developers.
Comment 6 User image Eric Shepherd [:sheppy] 2011-04-13 00:15:54 PDT
Does the theory that this builds something roughly the same as what we ship include building a universal 32-bit/64-bit binary on Mac?
Comment 7 User image Ted Mielczarek [:ted.mielczarek] 2011-04-13 04:45:36 PDT
No, that doesn't. I think that's not quite as useful. Note that you don't get a PGO build by default on Windows either. Both of those options add a lot to your compile time, but don't give you much in return if you just want a build you can run locally. People trying to replicate exactly what we ship are probably a smaller group than just people trying to build Firefox that's close enough to what we ship that they can usefully hack on it.
Comment 8 User image Ted Mielczarek [:ted.mielczarek] 2011-04-13 04:56:22 PDT
There's probably some value in an MDN document describing how to more-exactly reproduce what we ship on each platform.
Comment 9 User image Eric Shepherd [:sheppy] 2011-04-13 09:47:16 PDT
Agreed. I will file a bug to put it on the future roadmap, although realistically it's something that someone in releng might be better suited to produce.

Note You need to log in before you can comment on or make changes to this bug.