Closed Bug 644886 Opened 9 years ago Closed 9 years ago

Bookmarks and History menu sizing behaves badly

Categories

(Firefox :: Menus, defect)

4.0 Branch
All
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 625369

People

(Reporter: andyzweb, Unassigned)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

The bookmarks and history menus resize poorly in Firefox 4.0.
The toplevel menu always expands to accompany to fit the full title of the item instead of having a fixed width like before where it would truncate titles to look like "beginning of title...(skipped characters)...end of title"
It still maintains this behavior for the submenues though.
The problem I am talking about is in the red box of the screenshot. The ideal behavior is in the blue box

Reproducible: Always

Steps to Reproduce:
1.Have a bookmark with a really long title
2.Click `bookmarks`
3.Menu expands to full length of title
Actual Results:  
The menu was too wide

Expected Results:  
truncated the menu items and fit them into an appropriate width

Issue not effected by plugins and extensions.
Using the default OS X theme
Version: unspecified → 4.0 Branch
Attached image menu resize bug
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 625369
You need to log in before you can comment on or make changes to this bug.