The browser window freeze after update to v4

VERIFIED INVALID

Status

()

--
critical
VERIFIED INVALID
8 years ago
8 years ago

People

(Reporter: alexander.rolsdorph, Unassigned)

Tracking

4.0 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

Hi. I've been using FF for a long time. When I updated my home computer to FF v4, I can open Firefox, but after about 6 seconds it freeze (no matter how many tabs, current page beeing viewed etc). I can scroll the window up and down, but can't flip through the tabs, move the window or close it. When clicking anywhere in the browswer nothing happens and you get a windows sound. Kinda like: ding, ding, ding.. 

Reproducible: Always

Steps to Reproduce:
1. Install v4 from latest v3.6
2. Double click to open browswer from the taskbar
3. Wait 6-7 seconds for it to freeze
Actual Results:  
It freezes

Expected Results:  
Let me browse
Please try http://support.mozilla.com/en-US/kb/Safe+Mode and post the result here.
This doesn't sound like it's related to private browing.
Component: Private Browsing → General
QA Contact: private.browsing → general
(Reporter)

Comment 3

8 years ago
Hey. I thought it was private browsing - like me being a private person using a fx browser, but I guess that's a language barrier.

I've tried to innstall/uninstall fx again now without help - BUT I found something else that was interesting: it's only when I open the fx v4.0 from the taskbar it happens (and it still happens every time). While when I open it from Start > Fx shortcut it works fine.
Double clicking the entry on the taskbar may launch Firefox twice, you only need to press it once. However, it still shouldn't freeze.

Can you try Firefox safe mode (not the same as windows safe mode), using the link given in comment 1 please.

(In reply to comment #3)
> Hey. I thought it was private browsing - like me being a private person using a
> fx browser, but I guess that's a language barrier.

Private browsing is the name for a Firefox feature that makes Firefox temporarily stop saving browsing history, in case one was say 'looking up a birthday gift' on a shared computer. For more info, see:
http://support.mozilla.com/kb/Private+Browsing
Severity: minor → critical
Keywords: hang
Version: unspecified → 4.0 Branch
(Reporter)

Comment 6

8 years ago
Hey, sorry about the double reporting. I reported first while at work and then managed to forget I had done that in the 20 minutes it took me to get home : /

I've tried the Fx in safe-mode now and it works fine. I couldn't find the Safe-mode version in the Mozilla Firefox folder so had to get it opened by clicking Start, selecting Run (or use the Start Search box in Windows 7 and Vista) and then entering the following in the text field: firefox -safe-mode. Dunno if that matters.
That's ok :-)

Please can you try disabling all addons whilst in safe mode, then restarting Firefox in normal mode - and seeing if the problem goes away. 

If it does, it's caused by an addon, so enable them one by one (restarting Firefox after each for the change to take effect) to find the culprit, so it's author can be notified. Once found, please post the name and version of the addon - thanks!
Keywords: hang
(Reporter)

Comment 8

8 years ago
Hi

I've done this now, but not sure which one it was. Sorry. It works now at least :)
That's ok - thanks for the update anyway :-)

I'm going to mark this as invalid, since it wasn't a bug in Firefox.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Component: General → Extension Compatibility
QA Contact: general → extension.compatibility
Resolution: --- → INVALID

Comment 10

8 years ago
I've been using Firefox for years, and I've never had a single issue with any version, but I'm having this problem now. I've tried safemode, but I still get the same problem. Any word on an update or patch to fix this?
>but I'm having this problem now
You can't have this problem that the reporter of this bug reported because it works now for him.
>Any word on an update or patch to fix this?
You have to first identify a problem before it can be fixed and it's unknown if your specific problem is either a valid bug or is covered by another one.

Create your own bug if the safemode and a new profile doesn't help and attach a stacktrace of the hang in your report.
-> https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.