Flash applets load in separate tabs on page load [caused by NoScript]

RESOLVED DUPLICATE of bug 641372

Status

()

RESOLVED DUPLICATE of bug 641372
8 years ago
8 years ago

People

(Reporter: tomvalenz, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Caused by No Script], URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0

when going to the mentioned page, all the flash movies embedded will load up in a tab each. That means if there is 20 flash movies on the page they will all each load in a separate tab.

Reproducible: Always

Steps to Reproduce:
1. go to mentioned web site on linux firefox 4.0
2. watch movies load each in a tab of their own
3.
Actual Results:  
page should just load but instead firefox gets all messed up loading flash movies into tabs. really annoying, never seen this happen in previous releases.

Expected Results:  
page load correctly.

Comment 1

8 years ago
Works for me using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110325 Firefox/4.2a1pre ID:20110325030426

Could you see if the issue occurs if using Firefox in safe mode:
http://support.mozilla.com/kb/Safe+Mode

How about with a new, empty testing profile? (Don't install any addons into it)
http://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile

Updated

8 years ago
Component: Tabbed Browser → Plug-ins
Product: Firefox → Core
QA Contact: tabbed.browser → plugins
Version: unspecified → Trunk
(Reporter)

Comment 2

8 years ago
Problem on Linux Mint 10 32bit Firefox in safemode does not appear to do the strange behaviour.
(Reporter)

Comment 3

8 years ago
I should also mention that when I went into safe mode I did not check any additional boxes. If that helps.

Comment 4

8 years ago
An addon was likely the cause - please can you try enabling/disabling them one at a time (restarting Firefox after each for the change to take effect) to find the culprit, so it's author can be notified. Once found, please post the name and version of the addon - thanks!
(Reporter)

Comment 5

8 years ago
You are right, it is "No Script 2.0.9.9" causing the problems.

Comment 6

8 years ago
Thanks for the confirmation :-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Component: Plug-ins → Extension Compatibility
Product: Core → Firefox
QA Contact: plugins → extension.compatibility
Resolution: --- → INVALID
Whiteboard: [Caused by No Script]
Sounds similar and even like the same as bug 641372.
Resolution: INVALID → DUPLICATE
Summary: Flash applets load in separate tabs on page load → Flash applets load in separate tabs on page load [caused by NoScript]
Duplicate of bug: 641372
(Reporter)

Comment 8

8 years ago
You are right but then again the other problem is reported on Windows not Linux and the addon is still downloadable.

Comment 9

8 years ago
The addon author has been CCd in on the other bug so should be aware of the problem, and will need to fix - thanks!
You need to log in before you can comment on or make changes to this bug.