Closed Bug 645107 Opened 9 years ago Closed 6 years ago

required="no" triggers validation on a non-public real estate property search page

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: garif0, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/534.16 (KHTML, like Gecko) Chrome/10.0.648.18 Safari/534.16
Build Identifier: 4.0b12

Firefox 4.0b12 is currently validating fields on a form which does not require validation by our system.
For example,
A price field, we allow the user to leave the form field blank but Firefox prevents user from continuing.

This is the source code for that field.
						<tr><td class="field">LISTING PRICE:</td></tr>

									<tr><td>
										<input class="wf" name="priceline_1" value="" message="You must enter number in the 'Listing Price' field !" validate="integer" required="No" size="12" maxlength="32" type="Text">
										<select name="pricewise" size="1" class="wf" id="pricewise" tabindex="2"><option value="0" selected="selected">to</option><option value="1">or more</option><option value="2">or less</option><option value="3">exactly</option></select> 
										<input class="wf" name="priceline_2" value="" validate="integer" required="NO" size="12" maxlength="32" message="You must enter number in the 'Listing Price' field !" type="Text">
									</td></tr>

Unfortunately I cannot point you to the site as is a private site that requires authentication.


Reproducible: Always

Steps to Reproduce:
Happens all the time.
Actual Results:  
Firefox is automatically validates input form fields.

Expected Results:  
Should not validate the fields if it is not specified on the applications code base.
It's validating the fields because you have required="No" and 'required' is a boolean attribute in HTML5. When this attribute is specified on a field, a value has to be specified.

Is this website part of an intranet?
Component: General → DOM: Core & HTML
OS: Windows XP → All
Product: Firefox → Core
QA Contact: general → general
Hardware: x86 → All
Version: unspecified → Trunk
No.
It's a real estate property search.
It happens on the Listing Price and also the date range field

											<a href="javascript:void(0)" onclick="gfPop.fPopCalendar(openhouse.open_start_date); return false;" hidefocus=""><img name="popcal" src="/images/calendar/calbtn.gif" alt="" align="absmiddle" border="0" height="22" width="34"></a>
											<select name="sel_dt" size="1" class="wf" id="sel_dt" tabindex="3"><option value="0" selected="selected">to</option><option value="1">or later</option><option value="2">or earlier</option><option value="3">exactly</option></select>

											<input class="wf" name="open_end_date" value="" required="No" size="12" maxlength="10" type="Text">
											<a href="javascript:void(0)" onclick="gfPop.fPopCalendar(openhouse.open_end_date);return false;" hidefocus=""><img name="popcal" src="/images/calendar/calbtn.gif" alt="" align="absmiddle" border="0" height="22" width="34"></a>
										</td>
> It's a real estate property search.

OK, at what url?

The problem is that as currently specified in HTML5 |required="no"| means the same thing as |required="yes"| which means the same thing as |required=""|.  If the attribute is set, no matter what value it's set to, the element is required.  So the options are either to change the spec or get this site fixed if it's the only problem site we've run into so far.  For the latter, it would be good to know what site this is.
No.
It's a real estate property search, which is not accessible to the public.
It happens on the Listing Price and also the date range fields

											<a href="javascript:void(0)" onclick="gfPop.fPopCalendar(openhouse.open_start_date); return false;" hidefocus=""><img name="popcal" src="/images/calendar/calbtn.gif" alt="" align="absmiddle" border="0" height="22" width="34"></a>
											<select name="sel_dt" size="1" class="wf" id="sel_dt" tabindex="3"><option value="0" selected="selected">to</option><option value="1">or later</option><option value="2">or earlier</option><option value="3">exactly</option></select>

											<input class="wf" name="open_end_date" value="" required="No" size="12" maxlength="10" type="Text">
											<a href="javascript:void(0)" onclick="gfPop.fPopCalendar(openhouse.open_end_date);return false;" hidefocus=""><img name="popcal" src="/images/calendar/calbtn.gif" alt="" align="absmiddle" border="0" height="22" width="34"></a>
										</td>

Seems like for this we will have to update our code to remove anything that has the require="no".  This is legacy code in our system that has worked with no issues in previous versions of Firefox.
But as you described that is as specified on HTML5.

Thanks for your time.
> we will have to update our code to remove anything that has the require="no". 

That would be perfect.  Thanks!

Please resolve this bug once that's happened?
Assignee: nobody → english-us
Status: UNCONFIRMED → NEW
Component: DOM: Core & HTML → English US
Ever confirmed: true
Product: Core → Tech Evangelism
QA Contact: general → english-us
Summary: Auto validates form fields that require no validation → required="no" triggers validation on a non-public real estate property search page
Version: Trunk → unspecified
Let's assume this happened. :)
Assignee: english-us → nobody
Status: NEW → RESOLVED
Closed: 6 years ago
Component: English US → Desktop
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.