Fast scrolling when many different pictures are visible is very slow (sluggish, unresponsive)

RESOLVED WORKSFORME

Status

()

Core
Layout: View Rendering
RESOLVED WORKSFORME
7 years ago
5 years ago

People

(Reporter: mdinger.bugzilla@gmail.com, Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(6 attachments)

(Reporter)

Description

7 years ago
On this page the interface becomes sluggish and unresponsive when scrolling quickly over pictures.  To see this, quickly scroll (by dragging the scroll bar) over the area with pictures.  The interface should become at least slightly sluggish.

This is an issue with Firefox 4, latest trunk, and with older trunk versions (at least back to 2008/01/01).  So it should not be a regression (it is actually smoother on newer version than on older versions).

Steps to reproduce:
1. New profile
2. Load page URL (or testcase)
3. After fully loaded, grab scrollbar and drag quickly up and down over picture areas on page.

Result:
The interface should become sluggish or unresponsive for a little bit while over the pictures.

Desired Result:
An interface which is very responsive always.


Similar bugs:
Bug 417632 is similar but is a loading issue.  My issue happens even after loading is complete.
Bug 623499 may be the same but it is on XP and mine is on linux.


Build info:
Mozilla/5.0 (X11; Linux i686; rv:2.2a1pre) Gecko/20110325 Firefox/4.2a1pre
http://hg.mozilla.org/mozilla-central/rev/e11c2f95f781
(Reporter)

Comment 1

7 years ago
Created attachment 521903 [details]
min testcase
(Reporter)

Updated

7 years ago
Keywords: testcase
Component: General → Layout: View Rendering
QA Contact: general → layout.view-rendering
(Reporter)

Comment 2

7 years ago
I couldn't reproduce with only 1 image  

I can reproduce with Windows 7 with Firefox 4.  Setting OS to All.

Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0
OS: Linux → All
(Reporter)

Comment 3

7 years ago
Oops.  Didn't mean to post that yet.  This is to correct the first line.

I couldn't reproduce with only 1 image that was repeatedly used many times.  There had to be many different images.  I also had to reduce the number of images that were used to be able to upload it.  If you can't reproduce, try increasing the number of images used (images, not the number of times an image is reused).
If it has to be many different images and not several copies of the same one does that indicate it is something with decoding the images?
(Reporter)

Comment 5

7 years ago
Created attachment 522506 [details]
Placeholder picture

Firefox seems to have an issue with this picture.  I will reference this in another testcase.
(Reporter)

Comment 6

7 years ago
Created attachment 522514 [details]
min testcase 2

Simplified version of "min testcase".  Firefox seems to have an issue with a specific picture which I have already attached to this bug.
(Reporter)

Comment 7

7 years ago
Created attachment 522517 [details]
placeholder pic fast

This picture will be used in "min testcase fast".
(Reporter)

Comment 8

7 years ago
Created attachment 522520 [details]
min testcase fast

This testcase is the same as "min testcase 2" except it uses a different picture and so has much faster scrolling.
(Reporter)

Comment 9

7 years ago
Created attachment 522533 [details]
codeanalyst profile

Here is a CodeAnalyst profile in Windows 7.  Note however, it is much smoother in windows than it was in linux.

Is this a firefox issue?  It seems possible it could be a linux video card driver issue.  Particularly because the issue is much less noticeable in windows than it is in linux.
(Reporter)

Comment 10

5 years ago
I updated to ubuntu 12.04 and this is fixed.  I suspect improved drivers.

Machine specs:
Ubuntu 12.04
Linux 3.2.0-32-generic i686
xf86-video-ati 6.14.99 (bottom of "man radeon")

Mozilla/5.0 (X11; Linux i686; rv:19.0) Gecko/19.0 Firefox/19.0browser.startup.homepage_override.buildID 20121106030712

Marking WFM.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.