No way to tell when other tab groups are being used, appears that Firefox has no tabs open but really has many

RESOLVED DUPLICATE of bug 627251

Status

Firefox Graveyard
Panorama
RESOLVED DUPLICATE of bug 627251
7 years ago
2 years ago

People

(Reporter: LeiraHoward, Unassigned)

Tracking

Details

(Whiteboard: [dupeme?])

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

When using the new tab groups (Panorama), I set up several groups with different items in each. In the course of browsing the web, I closed all but one of those tabs, and found that, other than my own memory, there was no apparent way to tell that there were still tabs open in the other tab groups. This leads to a severely bloated (from the end-user's standpoint) browser. In my example, I still was using nearly 300,000k of memory, but was only showing one tab open.

I did remember that I had been using the tab groups, and was able to switch back and close them. However, for the average end-user, if there isn't some sort of visual aid to remind them that there are other tabs hidden (for instance, having the tab groups appear as separate buttons or tabs labeled with their name or "Tab Group 1"), then they won't be used.

(Note: I upgraded from Firefox 3.5.?? to this version, so if there IS such a feature, there may be an actual bug in that it doesn't appear properly with a browser upgrade.)

Reproducible: Always

Steps to Reproduce:
1.Open a lot of tabs (say, 10, for example).
2.Create tab groups, putting about 5 in each group.
3.Try to figure out how you would know that there are other tabs open, if you didn't already know that you'd made the groups. 
Actual Results:  
No way to tell that the other tabs were open. 

Expected Results:  
Some way to tell that there are other tabs somewhere!
(for instance, having the tab groups appear as separate buttons or tabs labeled with their name or "Tab Group 1")

I'm leaving this as "normal" because I think the fact that tabs disappear completely will be a "bug" to many end users (think grandparents and the non-tech savvy). 

I do like the fact that when you close the last tab, the Panorama window reappears, but for some people, when they are down to the last tab, they won't be trying to close it.

Updated

7 years ago
Whiteboard: [dupeme?]

Comment 1

7 years ago
Not sure if this is a straight dupe, but this bug would be mitigated by bug 591775. 

We might also want a way to figure out if you've got a tab open somewhere, but can't find it. Though I suspect that should be taken care of via a robust "search" feature.

Perhaps we should re-open bug 627251
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 591775
(Reporter)

Comment 2

7 years ago
Checking out the information in bug 591775, this is not a duplicate of that issue at all. It does appear to be a duplicate (or close to) of bug 627251 that you mentioned, so I am changing the duplication information to point to that (currently closed) bug instead. I'd suggest reopening bug 627251 as I do feel that it is an issue that should be resolved in a upcoming release.
Duplicate of bug: 627251
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.