Middle clicking certain links don't open them in a new tab

RESOLVED INVALID

Status

()

--
minor
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: m101010a, Unassigned)

Tracking

4.0 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

Middle clicking on the text links on that page will open them in a new tab while middle-clicking on the images will open them over the current page, which gets darkened (like Mozilla Addons does).

Reproducible: Always

Steps to Reproduce:
Middle click on the before or after images.
Actual Results:  
Image opens over the current page.

Expected Results:  
Image opens in a new tab.

This only happens on middle-click and not on right-click->Open in New Tab, and doesn't happen on similar sites, like Mozilla Addons.
Works for me using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110325 Firefox/4.2a1pre ID:20110325030426

Could you see if the issue occurs if using Firefox in safe mode:
http://support.mozilla.com/kb/Safe+Mode

How about with a new, empty testing profile? (Don't install any addons into it)
http://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile
Hardware: x86_64 → x86
Version: unspecified → 4.0 Branch
(Reporter)

Comment 2

8 years ago
This happens in a new profile and in that new profile in safe mode and a new profile in a different user account *and* in a new profile in the latest 64-bit nightly (Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:2.2a1pre) Gecko/20110325 Firefox/4.2a1pre).
This is not a bug.

The webpage uses a JavaScript that opens picture links within a lightbox. The picture itself it's wrapped in an <a href=> tag.
> <a rel="lightbox[screenshot]" href="http://userstyles.org/style_screenshots/45597_before.png">
<img class="screenshot multiple-screenshot" alt="" src="http://userstyles.org/style_screenshots/45597_before.png">
</a>

If you disable JavaScript you will see that the webpage behaves as expected, middle-clicking opens the image in a new tab.

If you edit the html, so that the <img> is not wrapped inside an <a href> then it behaves as expected, middle-clicking it does not open the picture.
> <img class="screenshot multiple-screenshot" alt="" src="http://userstyles.org/style_screenshots/45597_before.png">
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.