All users were logged out of Bugzilla on October 13th, 2018

The Firefox process keeps running in the background after closing the program.

RESOLVED INVALID

Status

()

--
critical
RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: linotechie, Unassigned)

Tracking

({hang})

4.0 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20110401])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

Ever since I upgraded to Fx4, the browser cannot be closed completely! Clicking on the close button does get rid of the browser window but that's only on the outer surface. The Firefox.exe process keeps running in the background and locks up a few files in the browser's profile folder and in the local app data folder. This has unfavorable consequences on the rest of the processes and leads to the system instability, insecurity, and inefficiency. Some applications/plugins (like Flash) refuse to install telling me that the browser Firefox needs to close first, while it's already closed (the fact is that the browser's process is still running in the background).

Further, whenever the browser is opened again from its shortcut, the browser does not start afresh; but the previously opened tabs start to load (this is a separate bug, being discussed here: "https://bugzilla.mozilla.org/show_bug.cgi?id=628043").

This was an issue with an old version of Firefox, I do not remember which one but it was pretty long back. Recent versions (3.6.x) managed to get rid of it. Unfortunately, the issue is back with the version 4.

Reproducible: Always

Steps to Reproduce:
1. Open Firefox 4. Let it fully load.
2. Browse through a few pages.
3. Close the browser.
4. Open the Task Manager and check the Processes tab for "firefox.exe".
Actual Results:  
The process is running and never ends of its own (I've tried waiting for about half an hour). The process is using memory and CPU cycles.

Expected Results:  
The process should exit as soon as the browser is closed. The process should also free up the system resources and locked files.

I'm using the default theme, no persona. I've removed a few of the extensions that I had in the version 3.6.15 (or whatever was the last one in the 3.6 branch), notably Tab Mix Plus and Chromin Frame (can't remember the others). I have installed the following new add-ons in version 4:

FormFox 1.7
Movable Firefox Button 1.3
NewTabURL 2.2.2
Status-4-Evar 2011.03.21.22

Updated

8 years ago
Version: unspecified → 4.0 Branch

Updated

8 years ago
Severity: major → critical
Keywords: hang

Comment 2

8 years ago
Works for me on Mozilla/5.0 (Windows NT 6.1; rv:2.2a1pre) Gecko/20110331 Firefox/4.2a1pre

I have tried several methods of closing FF4 and each time the browser was closed correctly. The firefox process is closed every time.

Also, could you see if the issue occurs if using Firefox in safe mode:
http://support.mozilla.com/kb/Safe+Mode

How about with a new, empty testing profile? (Don't install any addons into it)
http://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile

Comment 3

8 years ago
WFM Build identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

Any update algotechie?
Whiteboard: [bugday-20110401]
(Reporter)

Comment 4

8 years ago
Hi all. Sorry about being absent lately. Well, the issue seems to be an intermittent one, it starts happening at random, stays for 2 or 3 days, then vanishes for 2 or 3 days, and then appears again. Didn't experience the problem in the safe mode but I had tried that mode just to check the bug (and did not use this mode regularly for a few days). Looks like some extension is the culprit. Shall report if I figure. Thanks for the inputs.
Did you narrow down the extension? you may want to try a fresh profile, see if it happens there, if it doesn't install the same extensions you have in your other profile one by one.
(Reporter)

Comment 6

8 years ago
The issue is no longer present. Hopefully fixed by some unknown update or something.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID

Comment 7

8 years ago
Thanks for the update :-)
You need to log in before you can comment on or make changes to this bug.