Navigating is not working

RESOLVED WORKSFORME

Status

()

Core
DOM: Core & HTML
--
major
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

({regression})

2.0 Branch
mozilla2.0
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20110401], URL)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

Navigating on above mentioned website is not working as it worked in version 3.6.x
If you try to click on "BIOS" or "Hard drive" or "power management" or any other in this section you will not be navigated to the desired section.
It worked fine in version 3.6.x of firefox.

Thanks

Reproducible: Always
(Reporter)

Updated

7 years ago
Version: unspecified → 4.0 Branch

Comment 1

7 years ago
Works for me using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110328 Firefox/4.2a1pre ID:20110328103205

Could you see if the issue occurs if using Firefox in safe mode:
http://support.mozilla.com/kb/Safe+Mode

How about with a new, empty testing profile? (Don't install any addons into it)
http://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile

If it still occurs, please try using the latest nightly:
http://nightly.mozilla.org/
(Reporter)

Comment 2

7 years ago
I tested all recommended szenarios:
1. start firefox in a safe mode - navigation not working
2. created a new empty profile - navigating not working
3. installation of the latest nightly - navigating not working

(In reply to comment #1)
> Works for me using Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre)
> Gecko/20110328 Firefox/4.2a1pre ID:20110328103205
> 
> Could you see if the issue occurs if using Firefox in safe mode:
> http://support.mozilla.com/kb/Safe+Mode
> 
> How about with a new, empty testing profile? (Don't install any addons into it)
> http://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile
> 
> If it still occurs, please try using the latest nightly:
> http://nightly.mozilla.org/

Updated

7 years ago

Comment 3

7 years ago
WFM Build identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0.

Comment 4

7 years ago
Same thing here Build identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0
Unable to reproduce this bug in Firefox 4.2a1pre.  Can you try to create a screencast to display the issue?  We need more information to reproduce this bug.
Whiteboard: [bugday-20110401]
(Reporter)

Comment 6

7 years ago
If you are on the above mentioned web site and you try to click on "BIOS" or "Hard drive" or "power management" or any
other in this section you will NOT be navigated to the desired section. Firefox does not anything if you clock on those sections!
It worked fine in version 3.6.x of firefox.
I also tried in in the over night version 4.2a.1 version of march 29th. There the same symptomes came up. I did not work.
This is weird.  I'm completely unable to reproduce this bug.  Is there any other information you can provide that might help us reproduce this bug?
(Reporter)

Comment 8

7 years ago
Created attachment 523984 [details]
Picture 1

Picture 1
(Reporter)

Comment 9

7 years ago
@Anthony Hughes (:ashughes): If you open above mentioned web site you will see a screen loke in the attached picture 1. When you click on video will see a screen like picture 2. If this is so it is correct. But in my case it is NOT so. Nothing happens when you click on for example video. The screen stay as it is.
I could reproduce this issue on 4 different machines. XP and Windows 7. On all machines the same behaviour occured.
(Reporter)

Comment 10

7 years ago
Created attachment 523986 [details]
Picture 2

Picture 2
Ok, I'm finally able to reproduce this bug:
Mozilla/5.0 (Windows NT 5.1; rv:2.2a1pre) Gecko/20110406 Firefox/4.2a1pre
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110406 Firefox/4.2a1pre
Mozilla/5.0 (X11; Linux i686; rv:2.2a1pre) Gecko/20110406 Firefox/4.2a1pre

This is not reproducible on Mac though.  Seems like this might be restricted to Windows and Linux builds.

I'll work on trying to find a regression range for this bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regressionwindow-wanted
OS: Windows XP → All
Hardware: x86 → All
Last good nightly: 2011-02-11 
First bad nightly: 2011-02-12

Pushlog: 
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=1ed3464aaa92&tochange=9698ac3f1c61
Keywords: regressionwindow-wanted → regression
Moving to DOM:Core&HTML since it seems more appropriate than Firefox:General
Component: General → DOM: Core & HTML
Product: Firefox → Core
QA Contact: general → general
Target Milestone: --- → mozilla2.0
Version: 4.0 Branch → 2.0 Branch
Anthony, if you just load http://download.lenovo.com/lenovo/content/ddfm/MIGR-70443.html do you still see the problem on Linux and Windows?
(In reply to comment #14)
> Anthony, if you just load
> http://download.lenovo.com/lenovo/content/ddfm/MIGR-70443.html do you still see
> the problem on Linux and Windows?

Nope, works fine.
20160502172042 Mozilla/5.0 (Windows NT 5.1; rv:46.0) Gecko/20100101 Firefox/46.0
20160518030234 Mozilla/5.0 (Windows NT 5.1; rv:49.0) Gecko/20100101 Firefox/49.0

I have tested your issue on current version of website on latest FF release 46.0.1, latest Nightly build 20160518030234 and could not reproduce it. 
Closing this as Resolved-WORKSFORME. 
If anyone can still reproduce it, feel free to reopen the issue and provide more information.
Thanks
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.