Dotted border-bottom and border-top slower with hardware acceleration enabled

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: tceverling, Unassigned)

Tracking

({perf, testcase})

Trunk
x86
Windows 7
perf, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110326 Firefox/4.2a1pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.2a1pre) Gecko/20110326 Firefox/4.2a1pre

With hardware acceleration enabled, elements with "border-bottom: 1px dotted;" and "border-top: 1px dotted;" take much longer to render. Performance is restored when hardware acceleration is disabled.

Reproducible: Always

Steps to Reproduce:
1. Load test cases.
2. Switch to another tab and switch back.
3. Switch to another application and switch back.
Actual Results:  
Firefox will take unreasonably longer to render the "border-bottom" and "border-top" testcases, upon loading, upon tab switching and upon application switching. Firefox performs normally with the "border", "border-left" and "border-bottom" testcases.

Tested on Firefox 4.0 and Minefield built on 26-Mar-2011.

Expected Results:  
Firefox performing normally with all dotted border testcases.
(Reporter)

Comment 1

8 years ago
Created attachment 522111 [details]
Simple DIV dotted border-bottom testcase
(Reporter)

Comment 2

8 years ago
Created attachment 522112 [details]
Zipped testcases for dotted borders
Attachment #522111 - Attachment is obsolete: true
Component: General → Graphics
Keywords: testcase
Product: Firefox → Core
QA Contact: general → thebes
Version: unspecified → Trunk
Bas?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: perf

Comment 4

7 years ago
I'm not able to reproduce this on Nightly on Windows 7 (with hardware acceleration enabled). Please reopen if you're still seeing this.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.