Closed Bug 645340 Opened 13 years ago Closed 13 years ago

Firefox freezes and crashes the phone periodically.

Categories

(Firefox for Android Graveyard :: General, defect)

Firefox 4.0
ARM
Android
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: CoJaBo-Bugzilla, Unassigned)

Details

(Whiteboard: [testday-2011-06-24])

User-Agent:       Mozilla/5.0 (Linux; U; Android 2.2.1; en-us; DROIDX Build/VZW) AppleWebKit/533.1 (KHTML, like Gecko) Version/4.0 Mobile Safari/533.1 480X854 motorola DROIDX
Build Identifier: latest 4.0 from market (couldn't figure out how to copy text from about page in Firefox)

Firefox freezes and crashes the phone periodically (tested on Droid X).
I usually notice this when I have a few tabs open- at random points in time the phone will run very slow or freeze for a few seconds to a number of minutes. The freeze may resolve spontaneously, or may cause Firefox to exit, and will sometimes cause the phone to reboot. This usually happens to me after Firefox has been running for a while, when loading a new page, or unlocking the phone when it's been in standby overnight. Firefox need not be the foreground app, as it can freeze any time Firefox is still loaded. Terminating Firefox via task manager, if I am able to open it, resolves the freezing immediately.

This happens very regularly when running Firefox as primary browser, but there is unfortunately no specific action I've found that can trigger it.

Reproducible: Always
Similar to bug 644717?
I was not able to replicate bug 644717 on my Droid X (I dont have a Yahoo account so that may well be why, I just get the login screen), so I cant be sure-
however, that bug is for a force-close.
The issue I am experiencing results in, variously, an abrupt exit to home screen, total phone lock, or the phone spontaneously rebooting, but never a force-close dialog.
OS: Other → Android
CoJaBo, you said "Firefox freezes and crashes the phone periodically". 

Are there any crash ids for the crashes if you type about:crashes in the address
bar?
No. (In reply to comment #3)
> CoJaBo, you said "Firefox freezes and crashes the phone periodically". 
> 
> Are there any crash ids for the crashes if you type about:crashes in the
> address
> bar?

No- that page is empty.
I do not get any kind of crash dialog either- Generally, one minute its working, the next it will freeze, and after a minute or so, it goes straight to either the Android home screen or the Droid boot screen.
OS: Android → All
(In reply to comment #4)
> No. (In reply to comment #3)
> > CoJaBo, you said "Firefox freezes and crashes the phone periodically". 
> > 
> > Are there any crash ids for the crashes if you type about:crashes in the
> > address
> > bar?
> 
> No- that page is empty.
> I do not get any kind of crash dialog either- Generally, one minute its
> working, the next it will freeze, and after a minute or so, it goes straight to
> either the Android home screen or the Droid boot screen.

Which build? Have you tried a nightly [*] ?

[*] http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android-r7/fennec-6.0a1.multi.eabi-arm.apk
Mozilla/5.0 (Android; Linux armv71; rv:2.1) Gecko/20110318 Firefox/4.0b13pre Fennec/4.0)
Firefox crashes upon startup on my Motorola Droid X. It is usually after quitting (using the quit extension). Also, it glitches out and will show what looks like the left tab/window bar is open but frozen. In this incident, the phone must be restarted because force stopping firefox and ending the process do not fix it.
I am using the version of 4.0 from Market- will try the nightly now.

Comment 6 does not sound like the same bug-
This is not an on-startup crash, its intermittent and can take several hours of use to show.
I experience no graphical glitches, and terminating FF immediately resolves the hang as noted in the original report. Quit extension for me cleanly terminates Firefox. A hang that persists when Firefox is terminated points to some other app causing the issue.
The nightly has just crashed the same way after a few hours of on and off use (mostly facebook), followed by leaving it in standby for a while. I got an email, and when I unlocked and selected it from the taskbar (switching away from Firefox, which was the active app), the phone started running extremely slow. Manually killing Firefox in Advanced Task Killer immediately resolved the freezing. This is one of the typical ways it will crash.
CojaBo - You might try installing the Test harness addon which can provide us with some information about Fennec's memory and CPU usage:

http://starkravingfinkle.org/blog/2011/04/zippity-update-telemetry/
As of 4.0.1, Firefox hard-locks the phone much less frequently-
however, it is now returning to the Firefox-logo loading screen (and reloading all tabs when it starts) almost every single time I switch away then back to it (e.g., to copy something from elsewhere into a text input, only to find what I'd typed seconds ago was wiped out by the reload).
Occasionally, it doesn't even load the tabs automatically, just returns to the "tabs from last time" screen.

Is there a way to determine if this is still caused by a crash, or was something else changed to cause it to unload itself too frequently?
What's the most recent build (release, or nightly) that you've tried this with, trying to determine if it's still an issue.
OS: All → Android
Hardware: Other → ARM
Version: Trunk → Firefox 4.0
Whiteboard: [testday-2011-06-24]
My guess is that it may be the same or related to Bug 663494.  Would it be possible to go to about:crashes and see if there's a crash log listed?
4.0.1 no longer crashes since Gingerbread release. This was most likely an issue with the Droid X Froyo firmware. If this does not occur on other Android 2.2.1 devices, this bug can be closed.

This bug bears no resemblance to bug 663494, as it was a phone hard-lock, not a simple app crash.
closing based on comment 13
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
The bug is current. It happens for me as well.

I even bought System Tuner PRO to see who the hell eats my battery in half a day (to enable 1-minute interval logging for lots of time). After several days I also discovered that if I don`t use firefox (no capital letter, I`m really disappointed) the battery will hold for two days, and if I do, it won`t last 4 or 8 hours and phone gets really hot.

Device: Samsung Galaxy S2, GT-I9100
Android version: 4.0.4 Ice Cream Sandwich
Build number: IMM76D.BVLPH
Branded: Orange RO
Rooted: NO

Need any info? just ask.

Once, while I was asleep, I received an email with some results from doctor`s office and I had to open the webpage to see them. Unfortunately I did not close the browser and in the morning the phone was damn hot. It almost burnt my fingers! The problem is that it was charging and it could have melted (although I hate Samsung [I love HTC, but insurance did not had another HTC Desire HD to replace my shattered phone, so they gave me Samsun`], the phone did not caught fire, nor did it melt; maybe the battery life was affected by 8 hours of more than 50 degrees centigrade, but I can still get almost 2 days on 1 good charge). I opened task manager, I saw that firefox was eating up to 49.5% (that`s 100% on 1 core) I opened firefox (it was BADLY responding to commands), I selected quit, the browser "closed", but it remained in memory eating the same amount of CPU. I then killed it 5 minutes later and after another 10 minutes the phone started to be cooler.

I also get freezes no matter what I open in firefox (sometimes even if the respective site has a mobile view, so it`s not script-related). The freezes are sporadic and I cannot provide a set of steps to reproduce them, but the problem persists.

I cannot see any crash in about:crashes (there is only one from 4 weeks ago) related to any freeze of the browser. I just had one 15 minutes ago, I gave firefox 5 minutes to start responding but it didn`t. I have also created a set of screen captures within System Tunner PRO and I have the recording.

THERE IS A PROBLEM: Task Manager shows that firefox uses no CPU. But when I go in the task manager of System Tuner PRO, I see something like 460%... odd, but shows the truth. Once I started recording with System Tuner PRO, I saw that Firefox was constantly using 106.2% (darn, does this system tuner pro give me an extra cpu?) and ~119.8MB RAM. I was only searching google for some terms and before I started opening results in new tabs firefox started to move slowly. The fact is that the entire system is slowed down, not just this app.

If anyone has any question, I am more than willing to answer and provide additional data. I have some screen captures from System Tuner PRO and also a log recorder by this app (1 minute intervals).

Also, should anyone require more info on this or if there is a debug version of firefox, I`ll use it and provide you with the log files.

Kindest regards,
Dorin CHIRA,
Software Engineer, Industrial Automation
Would you please open a fresh bug for this. A logcat from the device would be helpful. In addtion a profile log could be helpful https://developer.mozilla.org/en-US/docs/Performance/Profiling_with_the_Built-in_Profiler though from reading the docs I believe that you will need to install a nightly build from http://nightly.mozilla.org to access the remote profiling feature.
***Just a note here, since this seems to come up as the first result for "freeze"-
This is a bug in Android 2.2 Froyo that results in a device hard-lock, that is triggered by Firefox and a few other apps. It's closed because this version is long obsolete.

As stated above, any new issues should be filled as new bugs, as they are not related to this issue.
Sure, no problem, I will file a new bug. I just caught the night build in the act.
Saved logcat, system tunner, but so far there is no profiler in FF. I can only hope that logcat is of use.
You need to log in before you can comment on or make changes to this bug.