If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[traceback] KeyError: u'name'

VERIFIED FIXED in 6.0.4

Status

addons.mozilla.org Graveyard
Admin/Editor Tools
P3
normal
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: krupa, Assigned: andym)

Tracking

unspecified
6.0.4

Details

(URL)

(Reporter)

Description

7 years ago
steps to reproduce:
1. Load https://addons.allizom.org/z/en-US/editors/queue/nominated?sort=name

traceback details:
 File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/core/handlers/base.py", line 111, in get_response
   response = callback(request, *callback_args, **callback_kwargs)

 File "/data/amo_python/www/preview/zamboni/apps/amo/decorators.py", line 22, in wrapper
   return func(request, *args, **kw)

 File "/data/amo_python/www/preview/zamboni/apps/editors/views.py", line 35, in wrapper
   return func(request, *args, **kw)

 File "/data/amo_python/www/preview/zamboni/apps/editors/views.py", line 166, in queue_nominated
   return _queue(request, ViewFullReviewQueueTable, 'nominated')

 File "/data/amo_python/www/preview/zamboni/apps/editors/views.py", line 140, in _queue
   page = paginate(request, table.rows, per_page=per_page)

 File "/data/amo_python/www/preview/zamboni/apps/amo/utils.py", line 105, in paginate
   paginated = p.page(page)

 File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/core/paginator.py", line 37, in page
   number = self.validate_number(number)

 File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/core/paginator.py", line 28, in validate_number
   if number > self.num_pages:

 File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/core/paginator.py", line 60, in _get_num_pages
   if self.count == 0 and not self.allow_empty_first_page:

 File "/data/amo_python/www/preview/zamboni/vendor/src/django/django/core/paginator.py", line 48, in _get_count
   self._count = self.object_list.count()

 File "/data/amo_python/www/preview/zamboni/apps/editors/sql_table.py", line 32, in __len__
   self._length = self.table.data.count()

 File "/data/amo_python/www/preview/zamboni/vendor/src/django-tables/django_tables/base.py", line 507, in <lambda>
   data = property(lambda s: s._get_data())

 File "/data/amo_python/www/preview/zamboni/vendor/src/django-tables/django_tables/base.py", line 505, in _get_data
   self._snapshot = self._build_snapshot()

 File "/data/amo_python/www/preview/zamboni/apps/editors/sql_table.py", line 63, in _build_snapshot
   actual_order_by = self._resolve_sort_directions(self.order_by)

 File "/data/amo_python/www/preview/zamboni/vendor/src/django-tables/django_tables/base.py", line 516, in _resolve_sort_directions
   if self.columns[rmprefix(inst)].column.direction == Column.DESC:

 File "/data/amo_python/www/preview/zamboni/vendor/src/django-tables/django_tables/base.py", line 261, in __getitem__
   return self._columns[name]

KeyError: u'name'

People may load old URLs via their awesome bar (particularly once /z is removed). We should not throw tracebacks
Assignee: nobody → amckay
Priority: -- → P3
Target Milestone: 6.0.3 → 6.0.4
Duplicate of this bug: 646533
(Assignee)

Comment 2

7 years ago
https://github.com/jbalogh/zamboni/commit/f5168acaea6dbb4d2ae3d8d4031c5c45a552393b
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Whiteboard: [pickme]
(Reporter)

Comment 3

7 years ago
verified @ 
https://addons.allizom.org/en-US/editors/queue/nominated?sort=age&dir=desc
https://addons.allizom.org/en-US/editors/queue/nominated?sort=name
Status: RESOLVED → VERIFIED

Updated

7 years ago
Whiteboard: [pickme]
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.