Does not complete the installation for 4.0

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Gypsy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

Two error message boxes show up one right after anther after downloading the plug in and then restarting. It says something like "Component returned failure code: 0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIFileInputStream.init]" nsresult: "0x80520012 (NS_ERROR_FILE_NOT_FOUND)" location: "JS frame :: chrome://1clickweather/content/js/utils/filemanager.js :: <TOP_LEVEL> :: line 233" data: no].   I noticed on one of the comments pages to "Go to http://releases.mozilla.org/pub/mozilla.org/addons/1035/ and right-click on 1-clickweather-1.1.9.1-fx.xpi then select Save As." well that did not work either.  Looks as if several people are complaining but no one is actually writing in if you check the comments section.  One person did add this " Thanks, Silverhawk, that worked great on my WinXP system. I was about to dump FF4, because this app is one of my top used add-ons that I use everyday.

The fix was easy just following the instructions below by Silverhawk. I downloaded the xpi file by right clicking on the big green "Add to Firefox" button above, and choosing "Save Link As". Then I used the free 7zip from http://www.7-zip.org/ , to right click on the downloaded file and choose 7-zip -> Open Archive. Right click on the "install.rdf" file on the list inside 7-zip and choose edit, make the changes, save and exit.

Now why can't the developer just go ahead and make these simple changes already and save a lot of people a lot of grief! Interesting also how the support link goes to weather.com and the link there only leads you back here, with no help anywhere - real clever for a developer named "ExceptionThinker"!

Glad to have my weather back - thanks again.
Now I don't know if that helps you but I don't write code so am not trying it myself.  

Reproducible: Always

Steps to Reproduce:
1.download one click weather 
2.restart
3.
Actual Results:  
Error messages appear boxes one right after the other, sometimes double or triple.

Expected Results:  

Weather to work.  Right now I have a green globe and to small blank squares with a NA in between them on the lower bar. 

Theme I am using is Purple Firefox, running XP Professional and Media Center Sony Thanks for fixing this!

Comment 1

7 years ago
You have to ask the developer of 1-clickweather, not Mozilla.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.