Closed Bug 645500 Opened 9 years ago Closed 8 years ago

Error in image rendering if zoomed while web console is shown in firefox 4.2a1pre

Categories

(Core :: Graphics, defect, minor)

x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: pietro.brenna, Unassigned)

References

()

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.2a1pre) Gecko/20110326 Firefox/4.2a1pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.2a1pre) Gecko/20110326 Firefox/4.2a1pre

If a single image is zoomed when web console is visible (I think not a problem with web console but generally with things placed on the top of the page frame) it generates rendering errors (the pixel around the image, so I think image margin/body padding/whatever are not re-drawn) since redraw is forced (for example scrolling, overlap another window...).
I'll soon post a screenshot to help my poor English.

Reproducible: Always

Steps to Reproduce:
1. navigate to an image, in my case png, but maybe other formats too?
2. ctrl-shift-k and open web console
3. ctrl + to zoom the image
Actual Results:  
Some pixels at top are not redrawn.

Expected Results:  
Pixels correctly rendered.
Attached image Screenshot
Dup Bug 641599 ?
Status: UNCONFIRMED → NEW
Component: ImageLib → Graphics
Depends on: 641599
Ever confirmed: true
Keywords: regression
QA Contact: imagelib → thebes
Probably.
In reply to comment #2)
> Dup Bug 641599 ?

You're right, I must have missed it when doing the research; the only differences is that in version 4.0b13pre (in bug 641599) the report does not mention an extra element on top of the browser frame; in fact in version 4.2a1pre it only happens, for some reasons I can't understand, only with the Web console shown; I propose dupe-ing and adding these elements to bug 641599. What do you think about that?
That bug will be fixed soon. We can just leave this open and resolve it as fixed if it does indeed get fixed by that bug.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.