SeaMonkey crashes on startup after downloading Firefox 4

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: rbsw, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

SeaMonkey 2.0.13 crashes on start up after I started using Firefox 4.0. At one time a message came up that said SeaMonkey was already open with no browser open. Safe boot does not help. Completely uninstalled Seamonkey and downloaded and reinstalled, no change. Created new user profile no change. 
I have two Macbooks that were using SeaMonkey, only put Firefox 4 on one and that's the one with no Seamonkey problem. Firefox 4.0 works fine. Not positive this is a Firefox issue but after three days of troubleshooting that's where I am.

Reproducible: Always

Steps to Reproduce:
1.Starts to display the browser window and crashes. 
2.after creating a new profile, sometimes it asks which profile to start.
3.Message just says, quit unexpectedly.
Actual Results:  
starts to open, crashes every time.


No crash report except from Console. First 25 step of 135.

Application Specific Information:
abort() called

Thread 0 Crashed:  Dispatch queue: com.apple.main-thread
0   libSystem.B.dylib             	0x9749c156 __kill + 10
1   libSystem.B.dylib             	0x9749c148 kill$UNIX2003 + 32
2   libSystem.B.dylib             	0x9752e899 raise + 26
3   libSystem.B.dylib             	0x975449b8 abort + 93
4   libstdc++.6.dylib             	0x93496fda __gnu_cxx::__verbose_terminate_handler() + 433
5   libstdc++.6.dylib             	0x9349517a __cxxabiv1::__terminate(void (*)()) + 10
6   libstdc++.6.dylib             	0x934951ba __cxxabiv1::__unexpected(void (*)()) + 0
7   libstdc++.6.dylib             	0x934952b8 __gxx_exception_cleanup(_Unwind_Reason_Code, _Unwind_Exception*) + 0
8   libFontParser.dylib           	0x9503267b TcmapEncodingTable::GetSubtable(unsigned short, unsigned short, unsigned short, unsigned short*) + 591
9   libFontParser.dylib           	0x95032406 TcmapEncodingTable::TcmapEncodingTable(TSFNTFont const&, unsigned short, unsigned short, unsigned short) + 170
10  libFontParser.dylib           	0x9503d29e TTrueTypeResourceFont::GetQDEncoding(unsigned short, unsigned short, unsigned short, unsigned short*) const + 60
11  libFontParser.dylib           	0x9503d221 TTrueTypeResourceFont::GetNFNTInfo(TNFNTFontInfo&) const + 475
12  libTrueTypeScaler.dylib       	0x9359d4ef CreateScalerFontBlock(fsg_SplineKey*, memoryContext*) + 2028
13  libTrueTypeScaler.dylib       	0x935b0a79 AssureScalerFontBlock(fsg_SplineKey*, memoryContext*, fontBlockCacheNode*&) + 48
14  libTrueTypeScaler.dylib       	0x9359cbef AssureStrikeBlocks(fsg_SplineKey*, memoryContext*, cacheStrike*, TStrikeDescription const*) + 82
15  libTrueTypeScaler.dylib       	0x9359c36b TTGetStrikeSpecs + 184
16  ...ple.ApplicationServices.ATS	0x9656edea HandleOFAScalerMessage + 1348
17  ...ple.ApplicationServices.ATS	0x9656e83a SendStrikeMessage + 162
18  ...ple.ApplicationServices.ATS	0x96571ddc _eOFAGetStrikeSpecs + 471
19  ...ple.ApplicationServices.ATS	0x9656c6a7 _eGetGlyphVectorIndex + 994
20  ...ple.ApplicationServices.ATS	0x9656bb4f OldGlyphsCacheStrike(TStrike*, void (*)(StrikeSpecs const*, void const*), void*) + 136
21  ...ple.ApplicationServices.ATS	0x9656b79d _eGCGetStrikeMetrics + 65
22  ...ple.ApplicationServices.ATS	0x9656a443 _eATSFontGetHorizontalMetrics + 173
23  ...ple.ApplicationServices.ATS	0x9656a37e ATSFontGetHorizontalMetrics + 76
24  org.mozilla.seamonkey         	0x00c09738 nsStopwatch::QueryInterface(nsID const&, void**) + 2315480
25  org.mozilla.seamonkey         	0x00c09db1 nsStopwatch::QueryInterface(nsID const&, void**) + 2317137
Firefox and Seamonkey use the same core but they are installed in different directories and should not affect each other.

The stack itself looks like Font related and it's in the OS X system libs ! 
Do you installed some fonts before your got the issue ?

You could also try a Seamonkey nightly build and start it with your new profile.
ftp://ftp.mozilla.org/pub/seamonkey/nightly/latest-comm-central-trunk/
(I'm currently using the SM nightly)
(Reporter)

Comment 2

8 years ago
Issue Resolved,  Bad Fonts in OS Font lib.
Don't know what caused the corrupt fonts

Thanks matti.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
marking wfm (fixed is only used with a patch)
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.