Select-scroll doesn't work on secondary monitor with maximized Firefox

RESOLVED DUPLICATE of bug 644621

Status

()

--
minor
RESOLVED DUPLICATE of bug 644621
8 years ago
8 years ago

People

(Reporter: Mac.Coombe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0) Gecko/20100101 Firefox/4.0

If I run Firefox on a dual-monitor setup, maximized and on the secondary monitor, I am unable to scroll downwards while selecting page content. This seems to be due to the fact that the page content now extends to the bottom of the screen due to there no longer being a permanent status bar. That is, the mouse doesn't leave the content area (because it extends to the maximum extent of the screen), so select scrolling is not invoked.

Reproducible: Always

Steps to Reproduce:
1. Run Firefox 4 on a dual monitor setup.
2. Place Firefox on the secondary screen (ensures there is no taskbar at bottom of screen).
3. Maximize Firefox (window and content now extend to bottom of the screen).
4. Load a page that has enough content to permit vertical scrolling.
5. Select content, and attempt to scroll downwards by extending selection out of the page.
Actual Results:  
No scrolling occurs.

Expected Results:  
Scrolling to occur.

While I understand why this behavior occurs, and agree that it is entirely reasonable given the circumstances, I think it should be simple to make it possible to scroll downward by simply adding a 1-pixel edge at the bottom of the screen, or allowing invoking of select-scroll behavior before the cursor leaves the page content.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 644621
You need to log in before you can comment on or make changes to this bug.