Firefox should allow split bookmarks (in the "split menus" sense)

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
7 years ago
3 months ago

People

(Reporter: pete, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.0; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: 

Bookmarks that are split:

1. should display as split menus in menu context.

+----------+----+
|***       |    |
|***       |  \ |
|*** foo   |  / |
|***       |    |
+----------+----+


2. should display as split buttons in toolbar context.

+----------+----+
|***       |    |
|***       |    |
|*** foo   | \/ |
|***       |    |
+----------+----+


= To create a split-bookmark, a new "New Split-Bookmark" menu item should appear.
= The properties for the split-bookmark should look exactly like a regular bookmark's properties.
= Deleting a split-bookmark should delete the bookmark and all children.

Notes:

1. "Open All in Tabs" on a folder containing a split-bookmark should open the url in the split-bookmark only, not any of its children.

2. "Open All in Tabs" should count split-bookmarks as a bookmark (and not as a folder) during the calculation to decide whether "Open All in Tabs" should be displayed or not (i.e. in a folder with <= 1 bookmarks, "Open All in Tabs" doesn't appear).

3. Split-Bookmarks should appear in the folder listings UI whenever you bookmark a page.


Reproducible: Always
(In reply to comment #0)
> 1. "Open All in Tabs" on a folder containing a split-bookmark should open the
> url in the split-bookmark only, not any of its children.

I don't understand what's the url in the split-bookmark and who are children?
Folders are containers of bookmarks, so they don't have an url, also because there is no url that could describe all contents. In this case you seem to suggest a url containing urls, so what's the use-case and rationale for this new kind of bookmark?
(Reporter)

Comment 2

7 years ago
A Split-Bookmark combines a folder and bookmark. So a Split-Bookmark is a url with children.

The essence of the usefulness is the 80-20 rule. For example, I have a "My eBay" url which I usually want to go to but I also have random eBay bookmarks to save me from hunting through their site for tasks I occasionally have to do. The "My eBay" bookmark is in my bookmarks toolbar and the rest are in an "eBay" bookmarks folder in the bookmarks menu. If I had split-bookmarks, I could simplify this using a single "eBay" split-bookmark in my bookmarks toolbar.



And as I was responding here, I thought of an alternative way to implement this than having a "New Split-Bookmark" menu item. What you can do instead is to right click on a bookmark and select "Use As Default". This will make the bookmark appear in bold and make the parent folder of the bookmark display as a split bookmark (and also inherit the favicon of the default bookmark). When you click on the folder, it will launch the url of its default bookmark. This is similar to how the search bar has a list of search engines and lets you change the default search engine.
Whilst I think this is an intriguing idea, I really can't see it being used by a lot of users, and it could be potentially confusing to some. For most users, they can easily open up an eBay bookmark from the address bar, or open the contents of a folder.

It might be something that extensions could experiment with, but I can't see us doing this in Firefox for general use.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.