inaccessible add ons window with n.v.d.a - causes crash

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
8 years ago
4 years ago

People

(Reporter: crazy-shawty, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.16) Gecko/20110319 FireDownload/2.0.1 Firefox/3.6.16 GTB7.1
Build Identifier: 

in firefox 4.0 and n.v.d.a. screen reader 2011 the add ons window is totally inaccessible. You are unable to scrole through the options or change the status of an add on or even uninstall or change an add on's options. after around 30 seconds of trying firefox freezes and so does n.v.d.a. sometimes firefox must be closed in task manager.

Reproducible: Always

Steps to Reproduce:
1. using n.v.d.a open the firefox 4.0 add ons window in tools using only key commandes.
2. try and manipulate the window using key commands and n.v.d..a's speech feedback.
3.



i feel that the add ons manager including the look and structure from firefox 3.6.16 should be brought back as it had no conflicts with n.v.d.a and was simple to understand for a blind user. also it din't crash or freeze.
Marco, can you confirm please?

Comment 2

8 years ago
I cannot confirm this with NVDA 2011.1 and Firefox 4.0, on either Windows XP with SP3  or Windows 7. The Add-Ons window works as expected, i can tab through it, install add-ons, remove them, search for them, switch tabs at will etc. Without freezes or crashes in either operating system.

Comment 3

8 years ago
Crazy-Shawty, did you submit the crash report to us when it came up? If not, please reproduce the crash one more time, and this time choose to send a report to Mozilla about the crash. If you've already done so, or now have done so, please do the following:

1. Open a new tab.
2. In the address bar, type about:crashes
3. In the table that appears, select the top-most link with the virtual cursor.
4. Press Applications key or Shift+F10.
5. Choose the "Copy Link" option. and press Enter.
6. Return to this bug page, and in a comment to the bug, please provide the link you just copied.
(Reporter)

Comment 4

8 years ago
i did send a crash report i always like to submit them. Here is the link.
http://crash-stats.mozilla.com/report/index/bp-98488091-e0d2-4201-8940-68e042110321
i think it links to the add ons crash but i sent a couple of reports around the same time.
(In reply to comment #4)
> i did send a crash report i always like to submit them. Here is the link.
> http://crash-stats.mozilla.com/report/index/bp-98488091-e0d2-4201-8940-68e042110321
> i think it links to the add ons crash but i sent a couple of reports around the
> same time.

Must be a dupe of bug 598578. Though you'd need to have running JAWS or other screen reader that we keep windows emulation for.
(In reply to comment #5)
> (In reply to comment #4)
> > i did send a crash report i always like to submit them. Here is the link.
> > http://crash-stats.mozilla.com/report/index/bp-98488091-e0d2-4201-8940-68e042110321
> > i think it links to the add ons crash but i sent a couple of reports around the
> > same time.
> 
> Must be a dupe of bug 598578. Though you'd need to have running JAWS or other
> screen reader that we keep windows emulation for.

yep, windows eyes is running
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 598578
(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #4)
> > > i did send a crash report i always like to submit them. Here is the link.
> > > http://crash-stats.mozilla.com/report/index/bp-98488091-e0d2-4201-8940-68e042110321
> > > i think it links to the add ons crash but i sent a couple of reports around the
> > > same time.
> > 
> > Must be a dupe of bug 598578. Though you'd need to have running JAWS or other
> > screen reader that we keep windows emulation for.
> 
> yep, windows eyes is running
> 
> *** This bug has been marked as a duplicate of bug 598578 ***

Perhaps that concerns to part of bug - a crash, I think Firefox isn't good when two screen readers are running on the system the same time, especially when we have specific handing for certain screen readers. So we might want to reopen it.

Comment 8

8 years ago
Yes, if you switch from Window-Eyes to NVDA and vice versa, you have to shut down Firefox first and restart it with the new screen reader running. Otherwise you get crashes like the above. So the sequence is, if you want to switch screen readers:
1. Shut down Firefox.
2. Shut down screen reader 1 (e. g. Window-Eyes).
3. Launch screen reader 2 (e.g. NVDA).
4. Relaunch Firefox.
(Reporter)

Comment 9

8 years ago
i had to start window eyes on top of n.v.d.a because the crash disabled n.v.d.a and i could only submit the crash report with speech and also had to close n.v.d.a in task manager.i use n.v.d.a as my main screen reader and have window eyes for crashes that disable n.v.d.a speech as this did.
So this bug sounds like a hang between the add-ons manager + NVDA, which turns into a crash if WE is loaded. Is that correct?
(Reporter)

Comment 11

8 years ago
i think that's right but when i loaded w.e it told me firefox was not responding so then i closed it in task manager and sent the error report. then i closed n.v.d.a in task manager so i could restart it again. before i restarted n.v.d.a i quit w.e because i hardly use it except when n.v.d.a speech goes firefox started up normal but if i go back to add ons i get the same thing. so i don't use add ons  at present.

Comment 12

8 years ago
Haven't seen any hangs, crashes or lag in the Add-ons Manager with NVDA myself. However, one other user did report sluggishness, though not freezes.

Is there any point in trying this in safe mode?
reopen bug, we need to find a way to reproduce the bug.

Do I understand right that you run Firefox and NVDA (and no other screen reader) and Firefox hangs on addons tab? First of all could you please try to disable your installed extension one by one and see if the issue goes away?
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
(Reporter)

Comment 14

8 years ago
I use n.v.d.a as my only screen reader yes, but the issue seems to have stopped with no warning or reason. I went to try and disable add ons and the tab opened like it should. I don't know why this has happened i installed "report incompatible add ons" extention and that installed ok. I can now also go through the list of add ons without it freezing, but it is still slow and jerky.
(In reply to comment #14)
> I use n.v.d.a as my only screen reader yes, but the issue seems to have stopped
> with no warning or reason. I went to try and disable add ons and the tab opened
> like it should. 

I didn't understand. Was original problem resolved because you disabled all addons or did it happen before you disabled them?
(Reporter)

Comment 16

8 years ago
the problem just went away with out me removing any add ons. I removed crawler toolbar and conduit in windows search feature as they wouldn't uninstall in control panel - could that have anything to do with it? both crawler and conduit had hidden their reinstall files in other programs and kept reinstalling until I used windows search to remove them.
Some extensions are part of application, perhaps that's you observe with crawler toolbar and etc. So that if you remove their extensions from Firefox UI then these applications aren't removed from your system sure.

You have dozen of installed extensions per your crash report (https://crash-stats.mozilla.com/report/index/bp-98488091-e0d2-4201-8940-68e042110321) and many of them has extension id but do not have extension name. Ideally I would love if you can find and point the guilty extension (i.e. an extension so that you're able to reproduce the problem when it's enabled and unable to see the bug when it's disabled). Could you try to do that?

Comment 18

4 years ago
Should we close this?
Resolving as WORKSFORME. Please reopen if you still see problems in the latest release of Firefox that reproduce this bug.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.