Neither "ESC" nor "ENTER" keys dismiss pref dialog

VERIFIED FIXED in M14

Status

P2
minor
VERIFIED FIXED
20 years ago
14 years ago

People

(Reporter: cpratt, Assigned: matt)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

20 years ago
build id: 1999051408
platform: windows nt

to reproduce: open the preferences dialog. press the escape (Esc) key. result:
the window is not dismissed.
expected result: the window is dismissed and changes are discarded.

Updated

20 years ago
Assignee: shuang → matt

Comment 1

20 years ago
Reassign it to Matt to fix it.

Updated

20 years ago
Target Milestone: M8
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M8 → M9
(Assignee)

Updated

19 years ago
Target Milestone: M9 → M10
(Assignee)

Updated

19 years ago
Target Milestone: M10 → M14

Updated

19 years ago
Priority: P3 → P2

Comment 2

19 years ago
There could be one of two possibilities:
(1) this a DUP of bug 18446 "Esc key does not dismiss the dialog", a
    simpler bug.
(2) the prefs dialog is sufficiently special or its buttons and keybindings are
    implemented sufficiently differently that this bug should be kept open for
    independent verification once 18446 is verified.

Also, quoting from bug 17569 "Pressing <ENTER> key in Dialogues should equate
to OK button":
  >----- Additional Comments From sdagley@netscape.com  1999-12-22 16:43 -----
  >Hangas asked for key behavior in dialog bugs to be sent his way...
Adding Hangas to the Cc: list.

Tested with 1999-12-23-08-M13 on NT, ESC did not dismiss the prefs dialog,
but did dismiss the dialogs reachable from the File menu. Given this, (1) does
not seem likely.

Updated

19 years ago
Summary: esc key does not cancel preferences window → Neither "ESC" nor "ENTER" keys dismiss pref dialog

Comment 3

19 years ago
Re-summarized to reflect "ENTER" key problem described in bug #22613.

Comment 4

19 years ago
Bug #17569 describes a general problem with "ENTER" key not dismissing dialogs.

Comment 5

19 years ago
*** Bug 22613 has been marked as a duplicate of this bug. ***

Comment 6

19 years ago
Actually, ESC should equate to a click on [Cancel], and ENTER to a click
on [Ok]... both of those events will dismiss the dialog, but only after
giving some feedback (and in the case of [Ok], saving the prefs).
See bug 22600 "Buttons that are triggered from keyboard should show visual
feedback" for details. If the fix for this bug is not identical to the fix
for bug 18446, that will need attention here too.
Blocks: 22613
QA Contact: cpratt → sairuh
No longer blocks: 22613
spam: reassigning QAcontact to me.
i cannot repro this on winNT or linux using the comm bits from 2000-01-20-08.
however, this seems to be a problem on mac using non-comm bits from
2000-01-20-08.

do other people see this still? if so, what platform[s]?
(Assignee)

Comment 9

19 years ago
this should be fixed
Not seeing the problem anymore
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
verif w/comm bits:

linux 2000-01-31-14
winNT 2000-01-31-08
macos 2000-01-31-11
Status: RESOLVED → VERIFIED

Comment 11

19 years ago
Bulk move of all Pref UI component bugs to new Preferences component.  Pref UI 
component will be deleted.
Component: Pref UI → Preferences
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.