Hang if I use "Clear recent History" with cookies included

RESOLVED DUPLICATE of bug 645471

Status

()

Firefox
General
--
critical
RESOLVED DUPLICATE of bug 645471
7 years ago
6 years ago

People

(Reporter: Vincent, Unassigned)

Tracking

({hang})

4.0 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0) Gecko/20100101 Firefox/4.0

Every time when I use "Clear Recent History" the browser just froze. Sometime it will un-froze after a few minute but most of the time it just crash. There's also a pop-up about stopping a script but I wasn't able to see which is it before it crash.

Reproducible: Always

Steps to Reproduce:
1.Browse the web for a certain period of time
2.Use "Clear Recent History
3.
Actual Results:  
The Browser froze and crashed as the result

Expected Results:  
in 3.6 the browser won't take a long time to clear the history and continue to let you surf. But in 4.0 it will pause all surfing and crash

I didn't use any theme it's basic.
does it crash if you uncheck "cookies" from the dialog? I suspect this is caused by clearing cookies for plug-ins.
Could you please check in about:crashes and post here the crash report id?
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> does it crash if you uncheck "cookies" from the dialog? I suspect this is
> caused by clearing cookies for plug-ins.
> Could you please check in about:crashes and post here the crash report id?

No It does not crash when I uncheck the cookies from the dialog. I think you might be right. The script pop-up when I check the cookies from the dialog after running the "Clear Recent History" w/o "cookies" first.

But regardless, without checking "cookies" from the dialog "Clear Recent History" are still slowing down the browser greatly, to the point that it stop all surfing process.
let's keep things separated, this bug is about crash/freeze caused by clearing plug-ins cookies, other stuff could be slow sure, but it is not causing a long freeze right? It is doing lots of IO so the fact browser slowdown could be understandable (depending on the system)
(Reporter)

Comment 4

7 years ago
The Freeze is about 5s~60s+ depend on how long I have been using FF. I think I might have a idea of why the Clear Recent History cause crash b/c of plug-ins:
http://img577.imageshack.us/img577/3952/bugzilla.png

I don't recall that FF 3.0 has so many plug-ins on the Process, in fact I don't think there is ANY.

Comment 5

7 years ago
Does the browser actually crash, or just freeze. If a crash please provide a crash id or stacktrace -> https://developer.mozilla.org/en/How_to_get_a_stacktrace_for_a_bug_report
Version: unspecified → 4.0 Branch
(Reporter)

Comment 6

7 years ago
Perhaps I have misinform the issue. It didn't crash. It freeze to the point that I have to force "End Process" from the Task Manager.

Comment 7

7 years ago
So to recap -> if you do Clear Recent History with all options selected you get a 5-60 second hang. If you uncheck clearing cookies then there is no hang. Is this correct?
Keywords: hang
Summary: Crash if I use "Clear recent History" → Hang if I use "Clear recent History" with cookies included
(Reporter)

Comment 8

7 years ago
Yes. That's correct.
It's this dupe of bug #645471 ?

Updated

6 years ago
See Also: → bug 645471

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 645471
You need to log in before you can comment on or make changes to this bug.