Issues connecting to wireless on Linux

RESOLVED DUPLICATE of bug 681742

Status

RESOLVED DUPLICATE of bug 681742
8 years ago
5 years ago

People

(Reporter: nmeyerhans, Unassigned)

Tracking

Details

(Reporter)

Description

8 years ago
Symptoms: Initial connection to Mozilla wireless is unreliable.  The wicd gui reports it as an authentication failure, but I suspect it's wrong about this because repeated connection attempts with the same stored password eventually succeed.  The kernel logs the following:

Mar 28 09:34:23 khan kernel: [  162.087621] Registered led device: iwl-phy0::radio
Mar 28 09:34:23 khan kernel: [  162.087651] Registered led device: iwl-phy0::assoc
Mar 28 09:34:23 khan kernel: [  162.087677] Registered led device: iwl-phy0::RX
Mar 28 09:34:23 khan kernel: [  162.087693] Registered led device: iwl-phy0::TX
Mar 28 09:34:23 khan kernel: [  162.102487] ADDRCONF(NETDEV_UP): wlan0: link is not ready

MAC Address: 00:24:d7:93:59:d0

Linux kernel is 2.6.32-5-amd64, as shipped with Debian 6.0.1

Wireless hardware is:
02:00.0 Network controller: Intel Corporation Centrino Ultimate-N 6300 (rev 35)
        Subsystem: Intel Corporation Centrino Ultimate-N 6300 3x3 AGN
        Flags: bus master, fast devsel, latency 0, IRQ 29
        Memory at f2400000 (64-bit, non-prefetchable) [size=8K]
        Capabilities: [c8] Power Management version 3
        Capabilities: [d0] MSI: Enable+ Count=1/1 Maskable- 64bit+
        Capabilities: [e0] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Device Serial Number 00-24-d7-ff-ff-93-59-d0
        Kernel driver in use: iwlagn

Intel firmware release 9.193.4.1

Comment 1

8 years ago
CC'ing jhford, who mentioned a similar problem using the default GNOME NetworkManager.
(Reporter)

Comment 2

8 years ago
Is everybody using Intel wireless hardware?
Our assumption is people are encountering problems with the iwlagn driver, specifically.

At the risk of sounding like HP Support, is anyone willing to take one for the team and manually upgrade to the latest driver?

http://linuxwireless.org/en/users/Download
i can, though, unlike HP Support, this driver requires the kernel-devel package
oh, and the exact same symptoms happen for me with NetworkManager
well, that fixed the problem by totally horking my wifi.  Now i don't get any authentication failures ;)
I think its worth mentioning that the failing to associate loop continues until NetworkManager finally realizes that there isn't a valid CA (or something else related to certs).  Once I say "ignore", it connects.

Comment 8

8 years ago
On Windows there's a checkbox to ignore cert validation - is there something like that on your OS?
The same problem happens to me in my school, ignoring cert doesn't change anything (for that you can try to delete the profile in NetworkManager and recreate it without cert, NM should ask you if you want to ignore cert).

Running "modprobe iwlagn 11n_disable=1 " as root makes things better for me, but not perfect.

Could you try it ?
also having this problem (in toronto), I'm using the iwlagn driver also. I get stuff like this in my logs:

May 19 09:29:20 aglon wpa_supplicant[1927]: Trying to associate with 00:1a:1e:2c:0b:80 (SSID='Mozilla Canada' freq=2462 MHz)
May 19 09:29:20 aglon NetworkManager[1879]: <info> (wlan0): supplicant connection state:  completed -> associating
May 19 09:29:20 aglon kernel: [ 4061.897214] wlan0: deauthenticating from 00:1a:1e:2c:0b:90 by local choice (reason=3)
May 19 09:29:20 aglon kernel: [ 4061.918259] cfg80211: Calling CRDA to update world regulatory domain
May 19 09:29:20 aglon kernel: [ 4061.958581] wlan0: direct probe to 00:1a:1e:2c:0b:80 (try 1/3)
May 19 09:29:20 aglon wpa_supplicant[1927]: CTRL-EVENT-DISCONNECTED bssid=00:1a:1e:2c:0b:80 reason=0
May 19 09:29:20 aglon NetworkManager[1879]: <info> (wlan0): supplicant connection state:  associating -> disconnected

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 681742
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.