Closed Bug 646027 Opened 9 years ago Closed 8 years ago

Add a space after last char of a long url

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: xti, Assigned: vingtetun)

References

Details

Attachments

(1 file)

Steps to reproduce:
1. Open Fennec App
2. Put the device in portrait mode
3. Browse to http://www.mozilla.com/en-US/firefox/features/
4. Wait until the page loads completely
5. Tap on URL Bar
6. Focus after the last character

Expected result:
The app is focused after the last "/" character.

Actual result:
It is hard to tap and focus after the last character. If a space (10px) will be added on the URL Bar before the Maginfying Glass button, it would make easier to tap after the last char on a long url address.
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:2.2a1pre)Gecko/20110329
Firefox/4.2a1pre Fennec /4.1a1pre
Device: Sony Ericsson Xperia X10
OS: Android 2.1 update 1
Attached patch PatchSplinter Review
The patch add an additional space of 16px to the end of input elements when you pan the inner content.
Note:  This does not change the size of the element itself but the size of the pannable content.
Assignee: nobody → 21
Attachment #522962 - Flags: review?(mark.finkle)
Attachment #522962 - Flags: review?(mark.finkle) → review+
http://hg.mozilla.org/mobile-browser/rev/173bf6f09ebb
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Verified on build: Mozilla /5.0 (Android;Linux armv7l;rv:2.2a1pre) Gecko/20110331 Firefox/4.2a1pre Fennec /4.1a1pre 
Device: HTC Desire (Android 2.2)
Status: RESOLVED → VERIFIED
Blocks: 653688
Sorry, this fix was completely broken.  I backed it out: https://hg.mozilla.org/integration/mozilla-inbound/rev/1ae169b47105

Marking this as WONTFIX because XUL Fennec is dead.  If this is still an issue for some reason, please fix it in a way which doesn't break all of the inputs on the web!
Status: VERIFIED → RESOLVED
Closed: 9 years ago8 years ago
Resolution: FIXED → WONTFIX
You need to log in before you can comment on or make changes to this bug.