Last Comment Bug 646028 - Add debug filter item to the Web Developer toolbar dropdown in Web Console
: Add debug filter item to the Web Developer toolbar dropdown in Web Console
Status: RESOLVED WONTFIX
[good first bug]
: dev-doc-complete
Product: Firefox
Classification: Client Software
Component: Developer Tools (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Sonny Piers [:sonny]
:
: J. Ryan Stinnett [:jryans] (use ni?)
Mentors:
Depends on: 616742
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-29 05:51 PDT by Rob Campbell [:rc] (:robcee)
Modified: 2011-11-21 07:15 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Rob Campbell [:rc] (:robcee) 2011-03-29 05:51:21 PDT
followup from bug 616742.

The other console api functions (log, info, warn, error) have filter options on the web console's toolbar. We should add one for debug as well when bug 616742 is landed.
Comment 1 Sonny Piers [:sonny] 2011-11-17 02:34:50 PST
Hi, since debug is an alias for log, should we not rename the item "Log" to "Log/Debug" ?
As far as I understand the code, console.debug() trigger a log message.
Comment 2 Sonny Piers [:sonny] 2011-11-17 07:58:59 PST
As discussed on IRC there is 3 options:

1) We modify the log filter menuitem to display "Log/Debug" instead of "Log"
2) We split log and debug so there are 2 different events triggered, and add a menuitem for debug filtering
3) We keep the current behavior (debug as an alias for log) and this is a wontfix

I think the best solution is 3 because we added console.debug() only for some websites breakages. (console.debug() is a firebug thing)

It is the chromium behavior. On node.js there is no console.debug method. On Opera dragonfly, log and debug have the same behavior and the web console output cannot be filtered. 

If we think the third solution is the good one (at least for the moment), we probably should explicitly deprecate the debug method in the web console documentation on MDN.
Comment 3 Kevin Dangoor 2011-11-17 08:51:11 PST
(In reply to Sonny Piers [:sonny] from comment #2)
> 3) We keep the current behavior (debug as an alias for log) and this is a
> wontfix

This choice seems fine to me, as long as we don't find users complaining about it being confusing.
Comment 4 Paul Rouget [:paul] 2011-11-18 05:08:55 PST
Can we won't fix this bug then?
Comment 5 Sonny Piers [:sonny] 2011-11-18 06:47:07 PST
Sheppy, how could we update the documentation on console API in such a way we don't encourage people to use console.debug ?
Comment 6 Jean-Yves Perrier [:teoli] 2011-11-21 07:15:06 PST
I've added a note to:
https://developer.mozilla.org/en/Using_the_Web_Console#section_6

Should be explicit enough :-)

Note You need to log in before you can comment on or make changes to this bug.