followup from bug 616742.
The other console api functions (log, info, warn, error) have filter options on the web console's toolbar. We should add one for debug as well when bug 616742 is landed.
Hi, since debug is an alias for log, should we not rename the item "Log" to "Log/Debug" ?
As far as I understand the code, console.debug() trigger a log message.
As discussed on IRC there is 3 options:
1) We modify the log filter menuitem to display "Log/Debug" instead of "Log"
2) We split log and debug so there are 2 different events triggered, and add a menuitem for debug filtering
3) We keep the current behavior (debug as an alias for log) and this is a wontfix
I think the best solution is 3 because we added console.debug() only for some websites breakages. (console.debug() is a firebug thing)
It is the chromium behavior. On node.js there is no console.debug method. On Opera dragonfly, log and debug have the same behavior and the web console output cannot be filtered.
If we think the third solution is the good one (at least for the moment), we probably should explicitly deprecate the debug method in the web console documentation on MDN.
(In reply to Sonny Piers [:sonny] from comment #2)
> 3) We keep the current behavior (debug as an alias for log) and this is a
This choice seems fine to me, as long as we don't find users complaining about it being confusing.
Can we won't fix this bug then?
Sheppy, how could we update the documentation on console API in such a way we don't encourage people to use console.debug ?
I've added a note to:
Should be explicit enough :-)