Last Comment Bug 646037 - Drop down menu disappears
: Drop down menu disappears
Status: RESOLVED FIXED
: regression, testcase
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: x86 Windows 7
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://www.arnb.org/suckerfishplus.html
Depends on: 646757
Blocks: 615794
  Show dependency treegraph
 
Reported: 2011-03-29 06:22 PDT by Arn Burkhoff
Modified: 2011-06-01 16:23 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Arn Burkhoff 2011-03-29 06:22:17 PDT
User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Windows NT 6.1; rv:2.0) Gecko/20100101 Firefox/4.0

When slowly moving the cursor from the top tab to one of the secondary tabs in a modified Suckerfish menu using Firefox 4 the drop down disappears. When the font size is increased using ctrl+ the problem eventually stops.

Reproducible: Sometimes

Steps to Reproduce:
1.Do a CTRL- to shink the font size
2.Place the cursor on Gobioidei
3.Very slowly move down to Burrowoin Gobies. At the point the cursor moves bewtween Gobioidei to Burrowing Gobies, the menu disappears.
4.if it does not occur keep shrinking the font size    
Actual Results:  
Failed


First noticed when updating to FF4 from FF 3.6.
Works as expected in FF 3.6 and older versions, IE9, Safari, Opera, Chrome

Seems to be related to the CSS as a standard Suckerfish page works correctly.

The workaround on my live site was to position to top of the drop downs a bit into the top of the upper level tabs. I've done many iterations of CSS adjustments to this page but can't find the culprit.

This is test/sample html file I made up to reproduce the problem
Comment 1 (mostly gone) XtC4UaLL [:xtc4uall] 2011-03-29 15:05:21 PDT
Confirmed against Mozilla/5.0 (Windows NT 5.1; rv:2.2a1pre) Gecko/20110329 Firefox/4.2a1pre ID:20110329030437

This is a Regression against 3.6. Does not happen on GC 12/Opera 11.
Comment 2 Srinivas 2011-03-31 04:01:15 PDT
Good nightly - Mozilla/5.0 (Windows NT 5.1; rv:2.0b9pre) Gecko/20110105 Firefox/4.0b9pre

Bad nightly - Mozilla/5.0 (Windows NT 5.1; rv:2.0b9pre) Gecko/20110106 Firefox/4.0b9pre

Pushlog - http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d2bd42931b03&tochange=c6e65b6259db
Comment 3 Boris Zbarsky [:bz] (still a bit busy) 2011-03-31 11:42:01 PDT
Looks a lot like bug 646757.
Comment 4 Robert O'Callahan (:roc) (email my personal email if necessary) 2011-06-01 16:23:08 PDT
Should have been fixed by bug 646757.

Note You need to log in before you can comment on or make changes to this bug.