Add Spark promo banner on mozilla.com/mobile page

VERIFIED FIXED in 2.4

Status

www.mozilla.org
General
--
major
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: Caitlin Looney, Assigned: jlongster)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Please add a Spark promo on the mobile home page (http://www.mozilla.com/en-US/mobile/) underneath the main download button. A banner similar to First Run banner would be an ideal shape, but we may want to call it out to make it a bit larger.
(Reporter)

Updated

7 years ago
Assignee: nobody → tshahian
Component: www.mozilla.com → Design
Product: Websites → Marketing
QA Contact: www-mozilla-com → design
Version: Firefox 4 → unspecified
(Reporter)

Updated

7 years ago
Severity: normal → major
Target Milestone: --- → blowfish-1.1

Comment 1

7 years ago
Thanks Caitlin. Would you mind attaching a screenshot of the First Run banner for reference?  Also, this bug is for the design only -- you'll have to file a separate website bug for the banner to actually get implemented. 

Is this an "asap" type of request?

CC-ing Lee to see if he can help us whip this up.

Comment 2

7 years ago
Caitlin, what is your desired copy?  " Play Spark >> "  ?

Comment 3

7 years ago
The way the site is set up now, I'd think that doing a text promo in the style
of the Spark one on http://www.mozilla.com/en-US/firefox/fx/ would be best. The
site design isn't really set up to put graphical promos down there across the
bottom.

We could also change the little circular promo bubble in the upper right to say
something about Spark.

Caitlin, what do you think? If that sounds ok to you then we can change this to
a website bug and have one of the devs build it out (skipping the design step,
basically).

Comment 4

7 years ago
John has a good point. I was trying to figure out how to fit in the promo under the download button without disturbing the rest of the design -- a heavy black banner like the F.R page wouldn't look right.  text based sounds much better (that's my vote), or perhaps weaving it into the promo as John described.

Another option is to put it inside the mobile phone image :) But I know that doesn't work too well.

Main CTA here is to download FF on your mobile device, and once they do, they'll see the Spark CTA in-product.  So, I wouldn't clutter up this page with that...
(Reporter)

Comment 5

7 years ago
Glow points right to this page so we should figure out a place to drive Spark traffic. I didn't mean the dark, black banner, but the light blue/white banner, similar to what you see on the new Firefox.com/m
(Reporter)

Comment 6

7 years ago
Ok, that works!

Comment 7

7 years ago
Sorry Caitlin... what were you referring to in comment #6?  I'm confused :)

I think plugging in a promo on that page is going to be challenging.  A simple text based option is the best (and cleanest) in my opinion.  John, what do you think?

Updated

7 years ago
Assignee: tshahian → nobody
Component: Design → www.mozilla.com
Product: Marketing → Websites
QA Contact: design → www-mozilla-com
Target Milestone: blowfish-1.1 → 2.0

Comment 8

7 years ago
Just moved this to a website bug. My reco is to repeat the promo from http://www.mozilla.com/en-US/firefox/fx/ at the bottom - Caitlin, which one should it replace? Also, do you want to put new text in the burst at the upper right?

The other question as whether this needs to wait until 2.0 (4/12) or if it should be rushed. Caitlin, let us know the urgency level.
OS: Mac OS X → All
Hardware: x86 → All

Comment 9

7 years ago
(In reply to comment #8)
My reco is to repeat the promo from
> http://www.mozilla.com/en-US/firefox/fx/ at the bottom - Caitlin, which one
> should it replace? Also, do you want to put new text in the burst at the upper
> right?

+1 to John's recommendation - using that burst + one of the bottom promo trios should really help drive traffic to spark, and we'll be able to implement this the quickest (no new graphics needed just a tiny bit of copy).

Comment 10

7 years ago
I think that's the decision...we just need someone to do it (and Caitlin to tell us the urgency level, per comment #8).
(Reporter)

Comment 11

7 years ago
Sorry for the delay. Firstly, +1 to John/Laur's recommendation. That sounds good. 4/12 is fine. We're working to add some enhancements to Spark, so perfect timing.

Comment 12

7 years ago
Thanks Caitlin. Laura, please assign this whenever you know who should work on it. Seems pretty quick & easy.

Comment 13

7 years ago
(In reply to comment #12)
> Thanks Caitlin. Laura, please assign this whenever you know who should work on
> it. Seems pretty quick & easy.

Sounds good but before dev can get started we need a few more details:

1. John - What exact copy should go in the burst? How about "Go Mobile. Play Spark" ?

2. John - the spark promo copy used on the homepage is: 
Have Fun and go mobile
Share Firefox 4 for Android - play Spark!
Start playing » 

The first line which contains the most noticeable copy won't make as much sense on the mobile page since it just restates mobile. Should this change? If so, to what?

3. Caitlin - What promo on http://www.mozilla.com/en-US/mobile/ should this replace? How about "browse more, type less"?
Assignee: nobody → jlong

Comment 14

7 years ago
(In reply to comment #13)
> 1. John - What exact copy should go in the burst? How about "Go Mobile. Play
> Spark" ?

Yes, perfect.
 
> 2. John - the spark promo copy used on the homepage is: 
> Have Fun and go mobile
> Share Firefox 4 for Android - play Spark!
> Start playing » 
> 
> The first line which contains the most noticeable copy won't make as much sense
> on the mobile page since it just restates mobile. Should this change? If so, to
> what?

Good catch. How about:

Go Mobile
PLAY SPARK
Share Firefox 4 for Android - play Spark!
Start the game>>
(Assignee)

Comment 15

7 years ago
implemented in r86903

I'm having trouble making the "burst" look good since there's a lot less text in it. Maybe make it smaller?

http://www-trunk.stage.mozilla.com/en-US/mobile/

Comment 16

7 years ago
Maybe just make it "Play Spark" then? Kind of like this:

PLAY
SPARK

Caitlin, is that enough text in that blurb?
(Assignee)

Comment 17

7 years ago
(In reply to comment #16)
> Maybe just make it "Play Spark" then? Kind of like this:
> 
> PLAY
> SPARK
> 
> Caitlin, is that enough text in that blurb?

The problem isn't too much text, it's too little. It might be ok the way it is, what do you think?

Comment 18

7 years ago
What if you put Play Spark on two lines instead of one? Maybe play around with the text size too (if necessary).

Comment 19

7 years ago
Sorry to jump in here late, but would it fit as:

Go Mobile
PLAY SPARK
(Reporter)

Comment 20

7 years ago
What's the status here? Are we on track for the next push? Thanks for confirming.
(Reporter)

Comment 21

7 years ago
What's the status here?

Updated

7 years ago
Target Milestone: 2.0 → 2.1
(Assignee)

Comment 22

7 years ago
(In reply to comment #21)
> What's the status here?

I'm finishing this up now. Sorry it got pushed back until now!

We just need to finish the design of the button. Here is is so far:

http://www-trunk.stage.mozilla.com/en-US/mobile/

I think it's bland, and I could try to add the text "Go Mobile" and play around with font-sizes.

Updated

7 years ago
Target Milestone: 2.1 → 2.2
(Assignee)

Comment 23

7 years ago
Any feedback?

Comment 24

7 years ago
It seems odd promoting Spark in the blue dot-whack - where it seems more fitting to say something like, "with 30% more!" vs. using it as a CTA. 

If we're set on using the burst for this, maybe we can re-introduce the text: "Go Mobile" or "Share Firefox" - so it reads more of a CTA and gives Spark more context?

I do like the Spark promo in the bottom pod still. Maybe since that's more descriptive, the simplified burst is ok. 

Not trying to bog this up again - these are just my reactions after re-visiting the mockup again.

Comment 25

7 years ago
Agree the copy seems out of context there. 

What about changing it to "Share Mobile"? At this point I think it's fine to use the dot-whack for this - the spark campaign won't go forever. 

Matej?

Comment 26

7 years ago
Also agreed with Lee in comment #24. Just saying "Play Spark" there feels like not
quite enough info.

I think the Go Mobile/Play Spark option as discussed in some of the earlier comments would be good...at least worth trying if James can make it work.
(Reporter)

Comment 27

7 years ago
Agreed. Thanks for everyone's comments. I know we're limited with space , but the more context the better.

Comment 28

7 years ago
Thanks John. 

James - here you go:

Copy: Go Mobile/Play Spark
Link: spark.mozilla.org
(Assignee)

Updated

7 years ago
Target Milestone: 2.2 → 2.3
(Assignee)

Comment 29

7 years ago
in trunk r88044

How does this look?

https://www-trunk.stage.mozilla.com/en-US/mobile/
(Reporter)

Comment 30

7 years ago
Looks good on my end.

Comment 31

7 years ago
Looks good (except the link should go to Spark). 

This looks ready for the 2.3 release today!

Updated

7 years ago
Target Milestone: 2.3 → 2.4
(Assignee)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Comment 32

7 years ago
pushed to stage r88287
pushed to production r88285
(Assignee)

Comment 33

7 years ago
missed a commit, pushed it to production r88289
verified-fixed https://www.mozilla.com/en-US/mobile/
Status: RESOLVED → VERIFIED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.