SourceForge SSL site freezes browser

VERIFIED FIXED

Status

()

--
minor
VERIFIED FIXED
18 years ago
14 years ago

People

(Reporter: r_pollak, Assigned: ddrinan0264)

Tracking

Other Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)
BuildID:    2001010504

It is not possible to browse https://sourceforge.net/, because Mozilla stops 
during displaying the page and does not react any longer.

Reproducible: Always
Steps to Reproduce:
Enter https://sourceforge.net/ in the navigation toolbar and press <return>.

Actual Results:  The page is displayed nearly completely (only some pictures 
are not shown), then mozilla freezes and has to be killed.

Expected Results:  The page looks the same as the non-SSL version 
http://sourceforge.net/ .

This bug disables logging in to SourceForge. You can try this by 
entering "mozillatest2" (without quotes) as login name and password at 
http://sourceforge.net/account/login.php .

All of this works with Netscape Communicator 4.76 .

I use an FTP, HTTP and SSL proxy.

Deactivating TLS (as proposed in http://bugzilla.mozilla.org/show_bug.cgi?
id=31174) or even deactivating SSL version 3 did not help.

If it is a SourceForge server problem, they could be contacted by filing a new 
bug in their bug tracker: http://sourceforge.net/bugs/?group_id=1 .

This is not http://bugzilla.mozilla.org/show_bug.cgi?id=63795, since I have no 
problem browsing other SSL sites, like https://www.ccc.de .

Comment 1

18 years ago
Reporter, r u using the latest build?  Although I am using a Mac with OS 9.0.4,
my build ID is higher than yours (mine being 2001010508).  I have no problem
loading the site or logging in.

Comment 2

18 years ago
Duplicate of bug 63057

*** This bug has been marked as a duplicate of 63057 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
This is no dupe of bug 63057.
Bug 63057 is only OS/2 and is marked invalid because OS/2 have no PSM yet.
This bug is on WIN2k and about a freeze
reopening
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
This should be a dupe of bug 47130 which is a dupe of bug 34834.
Bug 34834 is marked as verified fixed but see the last comment
in that bug from Warner Young.

cc: Javier Delgadil
and changing Produkt from Browser/Networking to PSM/Daemon
It seems, that I can´t change the Product.
I haven´t duped this bug because I´m not sure if this is really
a dupe of bug 34834.



Comment 6

18 years ago
I changed the product for you but there is no "Daemon" under component.  Beware
Component: Networking → Daemon
Product: Browser → PSM
Target Milestone: --- → M19
Version: other → 1.01

Comment 7

18 years ago
Ok turns out there is a daemon it just wouldn't let me @ it right away.
Changing version to unspecified because I am not familiar with the versions and
do not want to create a mess.
Version: 1.01 → unspecified
(Reporter)

Comment 8

18 years ago
I could reproduce the freeze with build 2001010804 (installed).
Out of 10 times, the bug did not appear 2 times, psm.exe crashed with an access
violation one time and mozilla froze 7 times.

In the freeze case I ended the processes mozilla.exe and psm.exe manually.
psm.exe always had 15 to 21 threads after freezing, compared to only 10 threads
when the bug did not appear.
In the freeze case no cpu time is used by mozilla.exe or psm.exe - contrary to
the description of to bug 34834.

Comment 9

18 years ago
Marking NEW as per comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: M19 → ---

Comment 10

18 years ago
Reassigning to default owner --> ddrinan
Assignee: neeti → ddrinan
(Reporter)

Updated

18 years ago
Severity: normal → minor
(Reporter)

Comment 11

18 years ago
I still get the same behavior with build 2001011704, but I found out:
Everything (login, looking at all the https pages, logout) works perfectly when 
I set "accept images from originating server only"!
With this workaround I can now wait for PSM 2.0 more patiently.

Comment 12

18 years ago
I don't get a freeze, but I can't SSL login to source forge.  Submitting a login
and a password cause mozilla to just sit.  A text error message in the launching
xtern however reveals:

Error loading URL https://sourceforge.net/account/login.php: 8007000e

Comment 13

18 years ago
the above is using the mozilla 0.7 tarball compiled on Linux 2.2.14
with gcc 2.95.2 (a mandrake 7.0 distro) and ./configure --enable-ldap
--disable-debug

Comment 14

18 years ago
Follow the instructtions at the following site to properly build PSM:

http://www.mozilla.org/projects/security/pki/psm/buildpsm.html
(Reporter)

Comment 15

18 years ago
I just tested this again with build 2001022705, installed on win2k.
The page https://sourceforge.net/ and the login page 
(https://sourceforge.net/account/login.php) were displayed correctly now, but 
after hitting "Login with SSL" mozilla still doesn't react any more.

The psm process has 13 threads at this time, mozilla has 23 threads, an both of 
them do not use any CPU time, contrary to bug 70520 (same page on linux).

Comment 16

18 years ago
Is this still a problem when using PSM 2.0?
(Reporter)

Comment 17

18 years ago
I cannot test this - I seem to have a local proxy problem with ssl sites. Can 
anyone else try?

Comment 18

18 years ago
Marking fixed. I have no problem logging into sourceforge.net (I'm not using a 
proxy)
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 19

18 years ago
Verified.
Status: RESOLVED → VERIFIED

Updated

14 years ago
Component: Security: PSM → Security: PSM
Product: PSM → Core
You need to log in before you can comment on or make changes to this bug.