Closed Bug 646288 Opened 10 years ago Closed 10 years ago

please update tegra-058, 059 dhcp mac addresses (comment 6)

Categories

(Infrastructure & Operations :: RelOps: General, task)

ARM
Android
task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: aki, Assigned: zandr)

Details

tegra-058
00:21:e8:70:c6:58

tegra-059
00:21:e8:70:c5:e1

were what I got by:

* plug in keyboard, usb leash, vga, power to tegra
* on imaging netbook, type

 adb shell am start -a android.settings.SETTINGS

About Phone -> Status -> Wi-Fi MAC address

(which I believe is the same as shows up in SUT when it finally comes back after trying to get an IP for ~5min)
Hm. Since that's a different OUI, I'm suspicious that the agent is giving up and displaying the WiFi MAC. Especially since it matches what About Phone lists for WiFi. I'm game to try putting those MACs into DHCP, but I suspect that they still won't work right.
Hm. Bob, am I looking at the right place for the MAC address?  I didn't see anything obvious for the ethernet port.

If this isn't it, I might try reimaging myself to see what happens.
If *that* doesn't work, we may have a couple of tegras to donate to developers who want to work via USB and/or wifi =P
Grabbing to see if I can save these guys.
Assignee: server-ops-releng → aki
Component: Server Operations: RelEng → Release Engineering
QA Contact: zandr → release
Summary: please doublecheck tegra-058, 059 dhcp mac addresses → reimage tegra-058, 059 to try to fix dhcp mac addresses
So the MAC address for the ethernet port is on the sticker attached to the board itself I believe. The MAC address displayed on the SUTAgent will either be the WiFi MAC as Zandr said, or the Bluetooth MAC if the WiFi cannot be determined.
Tracked in the larger pool in bug 646494.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 646494
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Bob found how to get the mac address:

1) attach usb leash
2) boot tegra
3) adb shell
4) logcat (this may require a large scrollback buffer).

The mac address is early on in the log.

Bob found that tegra-059 is actually 02:04:4b:0f:07:0d

We weren't able to get the tegra-058 mac address, but Bob's guessing 02:04:4b:0f:04:0a if they screwed up the sticker in the same way.

I'll add tegra-058 to the list of tegras to reimage.
Assignee: aki → server-ops-releng
Component: Release Engineering → Server Operations: RelEng
QA Contact: release → zandr
Summary: reimage tegra-058, 059 to try to fix dhcp mac addresses → please update tegra-058, 059 dhcp mac addresses (comment 6)
I'll update DHCP per the addresses suggested by comment 6.
Assignee: server-ops-releng → zandr
DHCP updated.
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Resolution: --- → FIXED
Component: Server Operations: RelEng → RelOps
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.