moz steals image extension when installing

VERIFIED DUPLICATE of bug 63870

Status

VERIFIED DUPLICATE of bug 63870
18 years ago
14 years ago

People

(Reporter: jkonrad, Assigned: hangas)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.01; Windows NT 5.0)
BuildID:    20010108

After installing Mozilla an my system, it became standard for all gifs, jpegs, 
pngs, etc. although I never told him to do so. Trying to remove this was rather 
hard: deinstalling Mozilla did not work, Mozilla.exe was still standard for all 
graphics. I had to tell each graphic format per hand to take Internet Explorer 
as standard again, and had to manually give each format the icon back that it 
had before I installed Mozilla (folder options). Downloading a browser should 
not have such devastating consequences, and should not take three hours to undo.

Reproducible: Always
Steps to Reproduce:
1.Install Mozilla on Win2000
2.
3.

Comment 1

18 years ago
Updating summary : your whole system was not ruined. :P
If you install mozilla (which I assume you no longer want to do ;)), and open
the preferences panel, then open the Advanced category, you will see a tab named
"Windows Integration" that allows you assign/deassign image extensions to mozilla.
Also you could just start Internet Explorer and ask him to steal back all the
image extensions (I remember IE doing that very well and quickly, you don't need
to ask him twice).
And sorry if changing 4 or 5 image extensions took you 3 hours...
Summary: whole system was ruined → moz steals image extension when installing

Comment 2

18 years ago
would you believe me if i told you that ie does the very same thing, and 
*shocking* it's a browser. *sigh*

recommend invalid, however i'm sending to UIDF
Assignee: asa → hangas
URL: none
Component: Browser-General → User Interface: Design Feedback
QA Contact: doronr → mpt

Comment 3

18 years ago
Well Mozilla will only associate with any file extensions if you answer 'Yes' to the dialog 
"Do you want this application to be the default for all file types it can handle" (or 
something like that), so it's the users responsibility to click no here.

HOWEVER: some people may assume by file types it means HTML, XML and other document types 
but NOT image types, therefore someone clicking Yes in the hope that Moz will open all 
their HTML documents may be a bit annoyed to find out their images no longer work in 
Photoshop.

My suggestion is, the installer asks what file types you want associated with Mozilla but 
will select sensible defaults. Offer to associate images with mozilla by default if IE or 
NS4.x handles images at present but if something else handles images asume it's a graphics 
package and make it the default for Mozilla not to associate with images.

Make the installer remember the original settings so that they can be restored on 
uninstallation, don't just assume the user was using IE, they have had the default set to 
Netscape 4.x, opera, etc instead.

Comment 4

18 years ago
if that's all, this is a dupe.
Keywords: qawanted
Whiteboard: DUPEME

Comment 5

18 years ago
As far as I can tell, this isn't a dup.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
Whiteboard: DUPEME

Comment 6

18 years ago

*** This bug has been marked as a duplicate of 63870 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
How is this a dup of 63870?  As far as I can see, that bug does not address the
fact that Mozilla's uninstaller does not restore the original file associations.

Comment 8

18 years ago
the reporter never mentioned uninstallation. we only guessed it.  I work under 
the premise that the reporter would have been happy enough to tell mozilla not 
to capture the file associations in the first place.

However, we hedged our bets and wrote a coherent bug requesting that the 
installer and uninstaller work to backup file associations.

If you care about the uninstaller support for restoring associations, please 
follow bug 64727.
Status: RESOLVED → VERIFIED

Updated

16 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.