Can't search bookmarks by description

VERIFIED WORKSFORME

Status

SeaMonkey
Bookmarks & History
P2
normal
VERIFIED WORKSFORME
17 years ago
13 years ago

People

(Reporter: mkaply, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({polish, regression})

Trunk
mozilla0.9.2
polish, regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fix in hand)

(Reporter)

Description

17 years ago
Latest nightly

Add some description to a bookmark.

Goto search->search bookmarks/history

Select Description on the left and put in a word that you put in the 
description.

No results display.

Comment 1

17 years ago
works for me on 2001010518 linux. Is it a regression?

Comment 2

17 years ago
Confirmed - Still seeing this

Platform: PC
OS: Windows 98
Mozilla Build: 2001022311


In addition Description is now named Comments in the Properties Menu.
Severity: normal → minor
Keywords: mozilla0.9.1, polish, regression

Comment 3

17 years ago
Word on the street is that bookmarks/history search is busted.  Should fix for 
beta1...
Keywords: nsbeta1, nsCatFood
yes we cant ship beta with search bookmarks busted. 
Keywords: nsbeta1, nsCatFood → nsbeta1+, nsCatFood+
Priority: -- → P1
Target Milestone: --- → mozilla0.9.1
Interestingly enough, I stumbled across this bug independently of reading this 
report while poking at the code, and I have a "fix in my tree."

Comment 6

17 years ago
nav triage team:

Check that fix in, dood!
Whiteboard: fix in hand
Checked in
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

17 years ago
Umm this is still busted for me. On all platforms with moz/comm. builds new/old profiles and
trying two different ways (Search Bookmarks from the Manage window, and Search Bookmarks/
History from Nav search menu) this behaves differently but is nonetheless busted.

In some cases I get no results in others it returned three bookmarks, none of which contained
the unique string('foopy') I added to the comments/description of one bookmark.

tested with 20010511 builds
Severity: minor → normal
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
nav triage: I reverse my earlier position. we can ship beta without this. 
deferring to m0.9.2. 
Target Milestone: mozilla0.9.1 → mozilla0.9.2
Interesting. my tests show this working (windows, relatively old profile)

The bug that you can still search bookmarks from the other window should 
probably be filed if it hasn't already. 

Updated

17 years ago
Priority: P1 → P2
This still works for me. Bookmarks, using the only dialog now available to 
search bookmarks. 

Claudius, can you still confirm that this is happening? 

Comment 12

17 years ago
WFM with 2001053108 builds
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 13

17 years ago
VERIFIED WFM with 2001053108 builds on all platforms
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.