If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

clicking items in Personal Toolbar don't work (node.getAttribute is not a function)

VERIFIED FIXED

Status

SeaMonkey
Bookmarks & History
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: Asko Tontti, Assigned: Blake Ross)

Tracking

({regression})

Trunk
x86
Linux
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fix in hand])

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.0-0.43.12 i686; en-US; m18)
Gecko/20010108
BuildID:    2001010806

When I click items in Personal Toolbar I will get error

JavaScript error:
chrome://navigator/content/navigator.js line 558: node.getAttribute is not a
function


Reproducible: Always
Steps to Reproduce:
- start mozilla
- select any item from Personal Toolbar

Actual Results:  JavaScript error:
chrome://navigator/content/navigator.js line 558: node.getAttribute is not a
function


Expected Results:  I expected browser to go selected item. If I selected Slashdot
from my Personal Toolbar I expected browser to go
http://www.slashdot.org/.


I tried to remove ~/.mozilla but that didn't help.

Previous version that I have used is 2001010512 and with it Personal
Toolbar works without problems.

Comment 1

17 years ago
I see the same problem on NT4.  Mozilla 010804 on NT4.
confirmed.

I'll cc blake, timeless and jag.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

17 years ago
Drat, you beat me to it :-)

Fix in hand
Assignee: ben → blakeross
Keywords: patch, regression, review
Whiteboard: [fix in hand]

Comment 4

17 years ago
Created attachment 22056 [details] [diff] [review]
[patch] event -> event.target
(Assignee)

Comment 5

17 years ago
ack! Thanks
Status: NEW → ASSIGNED
(Reporter)

Comment 6

17 years ago
I installed jag's patch and now it seems to work. Thanks for patch.
(Assignee)

Comment 7

17 years ago
checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

17 years ago
*** Bug 64692 has been marked as a duplicate of this bug. ***
*** Bug 64802 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
VERIFIED Fixed in 2001010908 build
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.