intermittent test_service_sync_updateEnabledEngines.js crash during XPCOM shutdown: Assertion failure: lock->owner == 0

RESOLVED DUPLICATE of bug 614480

Status

()

RESOLVED DUPLICATE of bug 614480
8 years ago
6 years ago

People

(Reporter: jfkthame, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1301472004.1301474635.18010.gz
s: talos-r3-xp-006
TEST-UNEXPECTED-FAIL | C:\talos-slave\test\build\xpcshell\tests\services\sync\tests\unit\test_service_sync_updateEnabledEngines.js | test failed (with xpcshell return code: -2147483645), see following log:
Thread 15 (crashed)
.....
###!!! ASSERTION: RECURSION_LEVEL(table_) > 0: 'RECURSION_LEVEL(table) > 0', file e:/builds/moz2_slave/cen-w32-dbg/build/obj-firefox/xpcom/build/pldhash.c, line 707
Net.Resource	DEBUG	PUT success 200 http://localhost:8080/1.0/johndoe/storage/meta/global
Assertion failure: lock->owner == 0, at e:/builds/moz2_slave/cen-w32-dbg/build/nsprpub/pr/src/threads/combined/prulock.c:212

Seen on tinderbox; intermittent failure, a re-run on the same changeset was green.

Perhaps a variation of bug 627985, which is a similar assertion-and-crash during shutdown, but the actual assertion seen is different so I didn't just star it as that bug.

Updated

8 years ago
Blocks: 438871
Whiteboard: [orange]

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 614480
Comment hidden (Treeherder Robot)
(Assignee)

Updated

6 years ago
Keywords: intermittent-failure
(Assignee)

Updated

6 years ago
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.