[OS/2] dropdown lists do not scroll using scroll button or arrows on the scroll bar

RESOLVED FIXED in mozilla5

Status

RESOLVED FIXED
8 years ago
4 years ago

People

(Reporter: losepete, Assigned: dragtext)

Tracking

2.0 Branch
mozilla5
x86
OS/2

Firefox Tracking Flags

(status2.0 .1-fixed)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (OS/2; Warp 4.5; rv:2.0b13pre) Gecko/20110327 Firefox/4.0b13pre SeaMonkey/2.1b3pre
Build Identifier: Mozilla/5.0 (OS/2; Warp 4.5; rv:2.0b13pre) Gecko/20110327 Firefox/4.0b13pre SeaMonkey/2.1b3pre

The scroll action that should occur with dropdown lists fails to work.

It looks to me as though there is no connection between seamonkey and the scroll button ie I click on the scroll button to drag it down (or up) but all that happens is the button jumps down (or up) and the contents jump with the button. Trying to drag the scroll button simply does not work.

Clicking on the scrollbar arrows does not work either; it simply closes the dropdown list.

To scroll the dropdown list it is necessary to use the keyboard.

Reproducible: Always

Steps to Reproduce:
1. Visit above example url
2. Click on a dropdown list arrow to display the choices available
3. Attempt to scroll using either scroll button or scroll arrows
Actual Results:  
Attempting to use the scroll button results in the scroll button jumping; it cannot be dragged.

Attempting to use the scroll arrows results in the dropdown list closing

Expected Results:  
When clicking on the scroll button I would expect the scroll button to be "dragable" up/down the scroll bar.

When clicking on the scroll arrows I would expect the scroll button to move.

Comment 1

8 years ago
Is this OS/2 specific? I can't reproduce this on Windows with 2.1b3pre or with Minefield.
It is probably OS/2 specific.  I do not see it on an Ubuntu box but do see problems with the scroll list on OS/2.  I can scroll as long as I don't try to use the scroll bar itself.  If I click above or below the scroll bar then the scroll bar will scroll but attempting a normal scroll will close the dropdown list.

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

8 years ago
Hmm. If you also see this with Firefox 4.0 on OS/X it's likely to be due to something in the widget code. CC some OS/2 person at random.
Version: unspecified → Trunk

Updated

8 years ago
Status: NEW → UNCONFIRMED
Ever confirmed: false
Version: Trunk → unspecified

Comment 4

8 years ago
Not sure why Dave changed the status, when he confirmed the problem as well.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

8 years ago
(In reply to comment #4)
> Not sure why Dave changed the status, when he confirmed the problem as well.

Accident :)

Comment 6

8 years ago
Verified the same problem is in Firefox 4.
Assignee: nobody → mozilla
Component: General → Widget: OS/2
Product: SeaMonkey → Core
QA Contact: general → os2
Hardware: Other → x86
Version: unspecified → 2.0 Branch

Updated

8 years ago
Assignee: mozilla → administration
Assignee: administration → nobody

Comment 7

8 years ago
FYI A similar problem has been reported against Windows XP in Bug 646821.

Comment 8

8 years ago
This has been bugging me at least since SM 20101204 on OS/2, but I can't reproduce in 2.1bX on Linux or WinXP.

Comment 9

8 years ago
(In reply to comment #8)
> This has been bugging me at least since SM 20101204 on OS/2

It was present in 20100322 which is the oldest build I have of gecko1.93 (SeaMonkey 2.1a1pre.
Perhaps Walter has an older build.
Bug 646821 seems disimilar to this one... he is having the problem scrolling in preferences in a non-dropdown window, whereas on OS/2 I, at least, can scroll preferences fine with that type of scrollbar (though I do get an occasional crash while scrolling through Helper Applications).  This problem seems to manifest itself just on dropdown lists.
His video showed he was under Advanced - Scripts & Plugins.
If I make the window small enough to produce a scroll bar it scrolls fine but under Privacy & Security - Validation and select Validate all certificates using the following OSCP server:  The Response Signer has a drop down.
I can scroll that dropdown via my wheel or by clicking above/below the actual scrollbar slider (in the white area in other words), or clicking the arrows at the top and bottom but trying to scroll via the more or less normal means of using the scrollbar slider does not work (it either causes the slider to jump some random amount or it closes the dropdown list).
(Assignee)

Comment 11

8 years ago
Created attachment 523974 [details] [diff] [review]
fixes scrollbars in popups
Attachment #523974 - Flags: review?(wuno)

Updated

8 years ago
Assignee: nobody → dragtext
Summary: dropdown lists do not scroll using scroll button or arrows on the scroll bar → [OS/2] dropdown lists do not scroll using scroll button or arrows on the scroll bar

Updated

8 years ago
Attachment #523974 - Flags: review?(wuno) → review+

Updated

8 years ago
Keywords: checkin-needed
Whiteboard: NPOTB, OS/2 file only

Comment 12

8 years ago
http://hg.mozilla.org/mozilla-central/rev/4991f1c5c3e0
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Whiteboard: NPOTB, OS/2 file only
Target Milestone: --- → mozilla2.2

Updated

8 years ago
Keywords: checkin-needed
Whiteboard: mozilla-2.0 a=NPOTB OS/2 files only

Comment 13

8 years ago
http://hg.mozilla.org/releases/mozilla-2.0/rev/cbe443e3f0e5
status2.0: --- → .1-fixed
Keywords: checkin-needed
Whiteboard: mozilla-2.0 a=NPOTB OS/2 files only
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.