Be able to re-order thunderbird tags

VERIFIED DUPLICATE of bug 528034

Status

Thunderbird
Preferences
--
enhancement
VERIFIED DUPLICATE of bug 528034
7 years ago
7 years ago

People

(Reporter: Adelino Rocha, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; Linux i686 on x86_64; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.2.15) Gecko/20110303 Lightning/1.0b2 Thunderbird/3.1.9

I have defined some tags but then I would like to re-order them. It is not provided an option to re-order tags.

Even deleting the tag and re-defining it natural behavior would be it to be at last position or after selected tag but instead it keeps in the same position as before.
I understand this behavior might be to avoid empty tag numbers or due to the existence of e-mails using that tag but I would suggest to let user choose if he/she wants to override or change tag numbering in e-mails even that that might implicate iterate all existing messages to change the tag number.


Reproducible: Always

Steps to Reproduce:
0. Preferences -> Display -> Tags
1. Define some tags (3 at least)
2. delete tag number 2
3. Select last existing tag
4. Define new tag (it should appear in last position)
5. Close preferences Window
6. Reopen Preferences -> Display -> Tags
7. Last defined tag appears in the position of deleted one (2)

Actual Results:  
There should be a way of re-order and preserve tags' order as specified by user even that required to process existing messages

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 528034
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.