flash player debugger gets reported as crashed when debugging takes long

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
7 years ago
5 years ago

People

(Reporter: Gustav Xyrer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

When debugging in flash, with flash player debugger, when a breakpoint is hit, flash builder is being open in debug mode and I can check all variables and stuff, the problem is that flash player suddenly stops working and I lose the debugging info because firefox kills it. In chrome, it displays a window asking what to do, which is optimal.

Reproducible: Always

Steps to Reproduce:
1. make project in flash builder and set a breakpoint
2. run project in debug mode
3. when breakpoint hits, wait a few minutes
Actual Results:  
Firefox kills flash player plugin thinking it has crashed

Expected Results:  
ask me if I want to wait for the plugin to respond or if it actually crashed and I want to kill it.

This problem is key for flash and flex developers, it's the main reason of why I don't use firefox as default browser, therefore I don't use it at all.

Updated

7 years ago
Whiteboard: DUPEME

Comment 1

7 years ago
This is probably the hang detector. These docs explain the situation and how to turn the hang detector off:

https://developer.mozilla.org/en/Plugins/Out_of_process_plugins/The_plugin_hang_detector

If this doesn't help let us know and reopen this bug.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.