If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Linux] Moz installer does not contain PSM files.

VERIFIED FIXED

Status

SeaMonkey
Installer
VERIFIED FIXED
17 years ago
13 years ago

People

(Reporter: John Unruh, Assigned: Sean Su)

Tracking

({pp})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
1.) Download the above build, and install with all options.
What is expected: That psm files would be installed.

Comment 1

17 years ago
this will required hacking to the installer config and deliver.pl scripts to
create the psm.xpi file.  We do have a Netscape PSM xpi so we might need to
investigate where that's coming from and probably change it to use the mozilla
one once it's created.

punting to sgehani as I won't have time to look at this.  cc leaf.
Assignee: granrose → sgehani
(Reporter)

Comment 2

17 years ago
Other 1/8/01 builds that are missing PSM files:
mozilla-i686-pc-linux-gnu-sea.tar.gz
mozilla-i686-pc-linux-gnu-0.6-installer.tar.gz
mozilla-i686-pc-linux-gnu-0.6.tar.gz

Updated

17 years ago
QA Contact: gemal → gbush
(Reporter)

Comment 3

17 years ago
QA > junruh since gbush is on vacation
QA Contact: gbush → junruh

Comment 4

17 years ago
How is this different from bug 63307?
(Reporter)

Comment 5

17 years ago
This is Linux. Bug 63307 is Windows.

Updated

17 years ago
Keywords: pp
Summary: Moz installer does not contain PSM files. → [Linux] Moz installer does not contain PSM files.
(Assignee)

Comment 6

17 years ago
reassigning to myself since Samir is on vacation till the end of this month.
Assignee: sgehani → ssu

Comment 7

17 years ago
*** Bug 66280 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
*** Bug 66151 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 9

17 years ago
Does anyone know which Setup Types the psm component should be in?
For the linux installer, here are the Setup Types:
  Typical (Navigator and Mail & News)
  Complete (Navigator, Mail & News, and Chatzilla)
  Navigator (Navigator Only)
  Custom (same as Complete, but user configurable)

If no one objects, I will be adding psm to all of the Setup Types.
Status: NEW → ASSIGNED
(Assignee)

Comment 10

17 years ago
Created attachment 23491 [details] [diff] [review]
patch to add psm to the mozilla installer.
(Assignee)

Comment 11

17 years ago
got an r=dbragg, looking for sr=

Comment 12

17 years ago
sr=mscott
(Assignee)

Comment 13

17 years ago
fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 14

17 years ago
is PSM supposed to be included in "nightly" mozilla-i686-pc-linux-gnu-sea.tar.gz
w/build ID 2001012611 ?

Asking because it doesn't get installed, and i thought this was the bug about that.

With above mentioned build I get this error-box whatever I choose to install -
also when PSM is explicitly checked in installer options:

Error [-621]: An installer module (.xpi) failed to install

When i afterwards run mozilla as root, this displays in console for each window
opened:
JavaScript error: 
chrome://communicator/content/securityUI.js line 29:
Components.classes['@mozilla.org/secure_browser_ui;1'] has no properties

In ~/mozilla-installer/xpi there is a file called psm.xpi, exactly 763 bytes
big. (mentioning that cause i thought it should be bigger)

Comment 15

17 years ago
From install.log:

-------------------------------------------------------------------------------
file:///tmp/.tmp.xi.0/bin/../psm.xpi  --  01/27/2001 00:24:41
-------------------------------------------------------------------------------

     Netscape Personal Security Manager
     ----------------------------------

     ** initInstall: 0
     ** communicatorFolder: /usr/local/mozilla/
     ** addDirectory() returned: -214

     Install cancelled by script
     ** cancelInstall() due to error: -214
     Finished Installation  01/27/2001 00:24:41
(Assignee)

Comment 16

17 years ago
that's because today's builds (all platforms) have psm build issues.  probably
won't get fixed till sometime over this weekend.  It's being looked at right now.
(Reporter)

Comment 17

17 years ago
Verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.