[traceback] KeyError: u'age'

RESOLVED DUPLICATE of bug 645429

Status

P4
normal
RESOLVED DUPLICATE of bug 645429
8 years ago
3 years ago

People

(Reporter: krupa.mozbugs, Assigned: kumar)

Tracking

unspecified
6.0.6

Details

(URL)

(Reporter)

Description

8 years ago
steps to reproduce:
1. Load https://addons-next.allizom.org/en-US/editors/queue/nominated?sort=age&dir=desc

traceback details:
File "/data/amo_python/www/next/zamboni/vendor/src/django/django/core/handlers/base.py", line 111, in get_response
   response = callback(request, *callback_args, **callback_kwargs)

 File "/data/amo_python/www/next/zamboni/apps/amo/decorators.py", line 22, in wrapper
   return func(request, *args, **kw)

 File "/data/amo_python/www/next/zamboni/apps/editors/views.py", line 35, in wrapper
   return func(request, *args, **kw)

 File "/data/amo_python/www/next/zamboni/apps/editors/views.py", line 166, in queue_nominated
   return _queue(request, ViewFullReviewQueueTable, 'nominated')

 File "/data/amo_python/www/next/zamboni/apps/editors/views.py", line 140, in _queue
   page = paginate(request, table.rows, per_page=per_page)

 File "/data/amo_python/www/next/zamboni/apps/amo/utils.py", line 105, in paginate
   paginated = p.page(page)

 File "/data/amo_python/www/next/zamboni/vendor/src/django/django/core/paginator.py", line 37, in page
   number = self.validate_number(number)

 File "/data/amo_python/www/next/zamboni/vendor/src/django/django/core/paginator.py", line 28, in validate_number
   if number > self.num_pages:

 File "/data/amo_python/www/next/zamboni/vendor/src/django/django/core/paginator.py", line 60, in _get_num_pages
   if self.count == 0 and not self.allow_empty_first_page:

 File "/data/amo_python/www/next/zamboni/vendor/src/django/django/core/paginator.py", line 48, in _get_count
   self._count = self.object_list.count()

 File "/data/amo_python/www/next/zamboni/apps/editors/sql_table.py", line 32, in __len__
   self._length = self.table.data.count()

 File "/data/amo_python/www/next/zamboni/vendor/src/django-tables/django_tables/base.py", line 507, in <lambda>
   data = property(lambda s: s._get_data())

 File "/data/amo_python/www/next/zamboni/vendor/src/django-tables/django_tables/base.py", line 505, in _get_data
   self._snapshot = self._build_snapshot()

 File "/data/amo_python/www/next/zamboni/apps/editors/sql_table.py", line 63, in _build_snapshot
   actual_order_by = self._resolve_sort_directions(self.order_by)

 File "/data/amo_python/www/next/zamboni/vendor/src/django-tables/django_tables/base.py", line 516, in _resolve_sort_directions
   if self.columns[rmprefix(inst)].column.direction == Column.DESC:

 File "/data/amo_python/www/next/zamboni/vendor/src/django-tables/django_tables/base.py", line 261, in __getitem__
   return self._columns[name]

KeyError: u'age'

People may load old URLs via their awesome bar (particularly once /z is
removed). We should not throw tracebacks
(Reporter)

Updated

8 years ago
See Also: → bug 645429
Assignee: nobody → kumar.mcmillan
Target Milestone: 6.0.4 → 6.0.6
Priority: -- → P4
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 645429
(In reply to comment #0)
> People may load old URLs via their awesome bar (particularly once /z is
> removed). We should not throw tracebacks

(In reply to bug 645429 comment #0)
> People may load old URLs via their awesome bar (particularly once /z is
> removed). We should not throw tracebacks

If you copied the words you wrote in the first bug, you might be filing a duplicate.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.