After some time: Address bar autocompletion stops working, CPU use up to 200% (file locking issue?)

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
8 years ago
8 years ago

People

(Reporter: p.bro, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.2a1pre) Gecko/20110329 Firefox/4.2a1pre
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.2a1pre) Gecko/20110329 Firefox/4.2a1pre

After surfing for some time, the CPU use goes up to over 100%, sometimes even 200% (2 full cores on a 16 core machine). At the same time, address bar autocompletion stops working, i.e. there are no more suggestions on pages to go to, and the icon at the left of the address bar changes to a rotating circle with four gaps.

To get back to normal, i have to quit the browser completely, is not linked to a specific tab. 

Reproducible: Always

Steps to Reproduce:
Happens every time after some time (sometime on the first page I browse, sometimes after minutes, sometimes after hours), but have not managed to find a way to reproduce it. It is as if there was a limited resource the browser at some time runs out of.


Actual Results:  
s. details above

Expected Results:  
Lower CPU use, address bar still suggests pages.

Special setup: Home directory (with firefox profile directory is on NFS imported volume). 

I sampled the process and will attach it to the bug.
(Reporter)

Comment 1

8 years ago
Created attachment 523047 [details]
Sample of the Minefield process taken at 103% CPU usage.
(Reporter)

Comment 2

8 years ago
Created attachment 523049 [details]
2nd Sample at almost 200% CPU usage

This sample was taken right after I clicked on "Submit" for the bug. The CPU usage increased from 103% to almost 200%, and I now have 4% system load that disappear when I exit Firefox (adding to the 12% load [200%/16cores] from the Firefox process)

Comment 3

8 years ago
Works for me on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.2a1pre) Gecko/20110410 Firefox/4.2a1pre

Also, could you see if the issue occurs if using Firefox in safe mode:
http://support.mozilla.com/kb/Safe+Mode

How about with a new, empty testing profile? (Don't install any addons into it)
http://support.mozilla.com/kb/Basic+Troubleshooting#w_8-make-a-new-profile
(Reporter)

Comment 4

8 years ago
OK, also happens with a brand new (blank) profile. 

But the problem does not appear, when my profile directory is on the local hard drive and not in the user home directory on the NFS share. Seems to be a locking issue in the NFS directory.
(Reporter)

Updated

8 years ago
Summary: After some time: Address bar autocompletion stops working, CPU use up to 200% → After some time: Address bar autocompletion stops working, CPU use up to 200% (file locking issue?)

Comment 5

8 years ago
Reporter, do you have anything new to add about this issue?
(Reporter)

Comment 6

8 years ago
Beyond the fact that a colleague of mine was also affected (Firefox 4 on NFS imported home volume), no. I've been running off a locally stored profile lately, which works perfectly, except for the fact that it is now my responsibility to back it up, and additionally it does of course not work, if I log in at a different machine (unlike it would if the profile was available there via NFS export). It seems to be a file locking issue, but I don't know enough of either Mac nor Firefox to see how this could be resolved.

Comment 7

8 years ago
Considering comment6, setting the resolution to Resolved Incomplete. When you have more information about this, feel free to reopen the issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.