Last Comment Bug 646660 - fp::pc should work on frames outside the current context
: fp::pc should work on frames outside the current context
Status: RESOLVED FIXED
fixed-in-tracemonkey
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: Brian Hackett (:bhackett)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-30 15:39 PDT by Brian Hackett (:bhackett)
Modified: 2011-04-26 15:38 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (8.89 KB, patch)
2011-03-30 17:18 PDT, Brian Hackett (:bhackett)
luke: review+
Details | Diff | Review

Description Brian Hackett (:bhackett) 2011-03-30 15:39:38 PDT
fp::pc currently only works on frames pushed by stack segments associated with the current context.  When recompiling in the JM+TI branch, we need to recompile and expand inline frames that can be on another context, but in the same compartment and StackSpace.

This requires fp::pc to walk all stack segments in the space.  Currently this would mean looking at every single frame in the thread, but it would be faster to just look at the start/end frames of each segment (since segments are continuous in memory).  This should be fixed too.
Comment 1 Brian Hackett (:bhackett) 2011-03-30 17:18:28 PDT
Created attachment 523172 [details] [diff] [review]
patch

Patch per the above.  This is a diff against JM, but will be the same on TM except for the Retcon.cpp change.  (Will push to JM before TM, to verify this fixes crashes seen on the JM tinderbox).
Comment 2 Luke Wagner [:luke] 2011-03-31 12:24:39 PDT
Comment on attachment 523172 [details] [diff] [review]
patch

Great.  I forgot about StackSpace::contains :)
Comment 3 Luke Wagner [:luke] 2011-04-12 11:58:08 PDT
Would you like me to land this?
Comment 4 Brian Hackett (:bhackett) 2011-04-12 12:17:36 PDT
Sorry, been meaning to land this but got sidetracked.  There haven't been anymore problems with fp::pc on the JM branch, so feel free to land if you don't mind.  Thanks!
Comment 5 Luke Wagner [:luke] 2011-04-12 13:05:07 PDT
http://hg.mozilla.org/tracemonkey/rev/3dc5d38ba870
Comment 6 Chris Leary [:cdleary] (not checking bugmail) 2011-04-26 15:38:35 PDT
http://hg.mozilla.org/mozilla-central/rev/3dc5d38ba870

Note You need to log in before you can comment on or make changes to this bug.