bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

ac_add_options --prefix=/usr/local/stow/xulrunner-central not respected by install script.

RESOLVED WONTFIX

Status

Firefox Build System
General
RESOLVED WONTFIX
7 years ago
5 months ago

People

(Reporter: kevand161, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.16) Gecko/20110323 Conkeror/0.9.2 (Debian-0.9.2+git100804-1)
Build Identifier: mozilla-central and mozilla-2.0

I'm trying to compile xulrunner from mozilla-central checked out from the mercurial repos. I've setup my mozconfig like so:

$topsrcdir/xulrunner/config/mozconfig
mk_add_options MOZ_OBJDIR=@TOPSRCDIR@/objdir-xul-release
mk_add_options MOZ_MAKE_FLAGS="-j3"

ac_add_options --prefix=/usr/local/stow/xulrunner-central
ac_add_options --with-system-zlib
ac_add_options --with-system-jpeg
ac_add_options --with-system-bz2
ac_add_options --with-system-cairo
ac_add_options --with-system-pixman
ac_add_options --enable-system-hunspell
ac_add_options --enable-optimize="${CFLAGS}"
#ac_add_options --enable-official-branding
ac_add_options --enable-canvas
ac_add_options --enable-strip
ac_add_options --disable-tests
ac_add_options --disable-installer
ac_add_options --disable-accessibility
ac_add_options --disable-updater
ac_add_options --enable-xinerama

Issuing a make -f client.mk works fine. However, when I issue make -f client.mk install, it goes for a little bit and then exits with this message.

cannot create /etc/gre.d/2.2a1pre.system.conf: Permission denied

I run make -f client.mk install as system user. My user has read/write/execute permissions to /usr/local. I've setup the install prefix to be /usr/local/stow/xulrunner-central in my mozconfig. The information provided by ./configure --help states that the sysconfdir defaults to [PREFIX/etc]. So why is it trying to install this file in my /etc directory? This happens with both mozilla-central and mozilla-2.0 checked out from the mercurial repos.

Reproducible: Always

Steps to Reproduce:
1.Try to install to /usr/local
2.install script tries to install to /etc and conradicts the build arguments passed.
3.permission errors
Actual Results:  
Program tries to write to /etc

Expected Results:  
Program writes to /usr/local/stow/xulrunner-central

I'm running debian squeeze x86_64

Comment 1

7 years ago
This is by design: whatever prefix xulrunner is installed to, it at runtime still looks in the global locations /etc/gre.d and ~/.gre.d. But this code is going away in bug 642795, and I don't want to change this on the branch, so I'm going to close this as WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX

Updated

5 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.