Javascript popups ignoring width,height parameters to window.open

RESOLVED INVALID

Status

()

Core
XUL
RESOLVED INVALID
17 years ago
17 years ago

People

(Reporter: Brian Landers, Assigned: Peter Trudelle)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
I've seen several duplicates of this bug, but they were all closed, and I'm
seeing the same behavior on the 01-06-01 Intel Linux build. Automatic (i.e.
onLoad) popups as well as ones from links seem to be ignoring height and width
and opening with the "remembered" size of the last resized window.

This is on Mandrake Linux 7.2, Gnome (Sawmill) window manager.

Testcase:
1. Navigate to http://www.bluecoat93.org/mozilla/popup_test.html
2. Click the Test button. Observe that a new window opens
3. Resize the window to a significantly smaller or larger size
4. Close the popup window
5. Click the Test button again. Observe that the new window opens to the resized
dimensions, NOT the specified width and height.

Comment 1

17 years ago
20001010808 linux build works as expected

Comment 2

17 years ago
Browser, not engine. Reassigning to XP Toolkit/Widgets for further triage -
Component: Javascript Engine → XP Toolkit/Widgets

Comment 3

17 years ago
Really reassigning -
Assignee: rogerl → trudelle
QA Contact: pschwartau → jrgm
(Reporter)

Comment 4

17 years ago
Ack, this looks like a window manager problem. I went back and tested with M18
and had the same problem. Based on Andrew's comment I tried switching window
managers and the problem went away. Sorry for the bother.

Comment 5

17 years ago
Marking as invalid per comments. Thanks for the followup, don't worry :)
Please reopen if you change your mind or if someone else finds good reasons to 
reopen this :-)
Fabian.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 6

17 years ago
Sawmill does things like that, there's some option you have to flip in order to
get it to do what you expect w/ moz. I second the resolve-invalid
You need to log in before you can comment on or make changes to this bug.