CPU 100% and memory usage runs away in two fx at the same time

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
8 years ago
5 years ago

People

(Reporter: Pike, Unassigned)

Tracking

({perf})

4.0 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

8 years ago
This happened to me for the second time now:

I run two Firefox 4.0 and one Minefield nightly in parallel, each on their own profile.

At some random point, both 4.0 browsers take a full CPU each, and allocate more and more memory. They're still somewhat there, but don't respond usefully. I.e., I can open a menu, but not select an item. They don't shut down either, I have to hard kill them.

I used the process monitor to analyze one of the two, while the second was already dead, three times, I'll attach them next.

To me the severity is major to critical, but I can't tell if this just happens with multiple instances, thus leaving at normal.

Josh, can you make sense out of this data? Is there something else I should do next time I hit this? Also, I remember that we've hit something like this on windows with a named semaphor or something, would you know if we have one of those on the mac, too?
(Reporter)

Comment 1

8 years ago
Created attachment 523252 [details]
first analysis log

First log of analysis. The second browser was already killed, this was at a 100% cpu and eating memory.
(Reporter)

Comment 2

8 years ago
Created attachment 523253 [details]
another analysis, 2 mins later

Another of those logs, 2 mins later, taken about a gig of memory now
(Reporter)

Comment 3

8 years ago
Created attachment 523255 [details]
windows closed, still running and eating mem log

Ok, last one. This is after I asked the process monitor to quit fx nicely, the windows were closed, but cpu and memory still running.

Forced quit after that, no crash report or so.
(Reporter)

Comment 4

8 years ago
I ran into this this morning again, after waking up my macbook.

I again saw a host of xpc_LocalizeContext chunks in the analysis. I killed one of the two and let the other one running hoping I'd get some debug tips from irc, but now it get its act back together and sits there working nicely.

Updated

8 years ago
Version: Trunk → 4.0 Branch
We are experiencing a similar problem, as commented here:

https://bugzilla.mozilla.org/show_bug.cgi?id=655235#c8

However, we also experienced the issue with only one Fx instance running.

We initially thought the problem could have been caused by a bug in the add-on we are developing, but when we issue occurred in a profile that doesn't have the add-on installed, we started wondering if the problem could be in the FF4 itself, as it never happened on Firefox 3.6.

As mentioned in the referenced comment, we are willing to provided further information that leads to the cause of this problem.

Comment 6

5 years ago
Do you still see this issue? 

I saw something like this 3-4 years ago, but on Windows.
Never nailed it down. But it went away.
Severity: normal → major
Flags: needinfo?(l10n)
Flags: needinfo?(juan)
Keywords: perf
(Reporter)

Comment 7

5 years ago
I don't remember this ;-)

I suggest to resolve this WORKSFORME.
Flags: needinfo?(l10n)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(juan)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.