large number of addons causes FF4 to hang

RESOLVED DUPLICATE of bug 637286

Status

()

--
critical
RESOLVED DUPLICATE of bug 637286
8 years ago
8 years ago

People

(Reporter: zoli4290, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.16) Gecko/20110323 Linux Mint/10 (Julia) Firefox/3.6.16
Build Identifier: Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0

I try to use a large number of extensions (>50). When I install them one by one and reach a total of 24, Firefox hangs. Up to 23 addons it works, but after installing the 24th extension (no matter what extension title/type is) and restart Firefox hangs immediately with only window frame on screen and no content drawing. It also becomes unresponsive. Its process must be killed to terminate.

Reproducible: Always

Steps to Reproduce:
1.install 23 addons and restart when necessary
2.install 24th and restart
3.
Actual Results:  
FF4 hangs and becomes unresponsive

Expected Results:  
FF4 runs OK, can be used and further addons can be installed

After upgrading 3.16 from PPA http://ppa.launchpad.net/mozillateam/firefox-stable/ubuntu phenomenon can be reproduced on
- real system on LinuxMint10 Gnome 64-bit
- fresh VirtualBox installation with LinuxMint10 LXDE 32-bit guest on LinuxMint10 Gnome 64-bit host
- fresh VirtualBox installation on LinuxMint10 Gnome 64-bit guest on LinuxMint10 Gnome 64-bit host
(Reporter)

Comment 1

8 years ago
User-Agent may be wrong as I reported the bug from FF3.16.
Build Identifier copied from FF4 under issue in LinuxMint 10 LXDE 32-bit.

Build Identifier form 64-bit: Mozilla/5.0 (X11; Linux x86_64; rv:2.0) Gecko/20100101 Firefox/4.0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 637286
You need to log in before you can comment on or make changes to this bug.