The local XML file './data/bugzilla-update.xml' cannot be created.

RESOLVED INVALID

Status

()

Bugzilla
Administration
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Eric Peskin, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_7; en-us) AppleWebKit/533.20.25 (KHTML, like Gecko) Version/5.0.4 Safari/533.20.27
Build Identifier: Bugzilla 4.0

When I log into the administrator account of my new Bugzilla installation, I see the message:

"The local XML file './data/bugzilla-update.xml' cannot be created. Please make sure the web server can write in this directory and that you can access the web. If you are behind a proxy, set the proxy_url parameter correctly."

This is strange, because:
1)  I can access the web.
2)  I am not behind a proxy.
3)  The permissions are as follows:
drwxr-x--- 16 root apache 4096 Mar 31 10:46 /var/www/html/bugzilla/
drwxrwx---  7 root apache 4096 Mar 31 14:11 /var/www/html/bugzilla/data

Reproducible: Always

Steps to Reproduce:
1.  Install Bugzilla 4.0 from http://ftp.mozilla.org/pub/mozilla.org/webtools/bugzilla-4.0.tar.gz
2.  Log in with administrator account.
3.  Set basic parameters on urlbase and cookiepath.
4.  Log out.
5.  Log back in with administrator account again.
Actual Results:  
The following message appears in a red box at the top of the Bugzilla Main Page:

"The local XML file './data/bugzilla-update.xml' cannot be created. Please make sure the web server can write in this directory and that you can access the web. If you are behind a proxy, set the proxy_url parameter correctly."

Expected Results:  
I would expect the main page without the error message.  (I would also expect that Bugzilla should be able to create that file if it needs to.)

I searched http://groups.google.com/group/mozilla.support.bugzilla and also the web in general.  I found other cases where people got the same error message.  But they seemed to be in different contexts and I could not find a solution that helped.

Here is some information about my system:

[root@koi-test data]# uname -a
Linux koi-test.vz30.nyumc.org 2.6.18-238.1.1.el5 #1 SMP Tue Jan 18 18:49:37 EST 2011 x86_64 x86_64 x86_64 GNU/Linux
[root@koi-test data]# cat /etc/redhat-release 
Scientific Linux SL release 5.4 (Boron)
[root@koi-test data]# rpm -q httpd mysql mysql-server perl
httpd-2.2.3-43.sl5.3.x86_64
mysql-5.0.77-4.el5_5.4.x86_64
mysql-server-5.0.77-4.el5_5.4.x86_64
perl-5.8.8-32.el5_5.1.x86_64

Comment 1

7 years ago
Well, based on the trouble you had in bug 646668 to correctly read files from the web browser, I wouldn't be surprised you have some other oddities in your system. Also, you by far don't give enough information to debug the problem. This rather looks like a support question. See http://www.bugzilla.org/support for help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.