Pin Tab as App - Perception Issue

RESOLVED DUPLICATE of bug 645549

Status

()

RESOLVED DUPLICATE of bug 645549
8 years ago
8 years ago

People

(Reporter: rvjanc, Unassigned)

Tracking

4.0 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0
Build Identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0) Gecko/20100101 Firefox/4.0

The feature "Pin Tab as App" is causing a fair amount of confusion on mozillazine; I don't know how wide spread this is.

Misconception #1 - When one goes to a cloud app like Gmail and pins the inbox, users expect that when you open FF the pinned tab will go to the inbox. However, if you were in the sent mail folder when you quit FF, the pinned tab will open in the sent mail folder or, wherever you were when you quit the browser. Users' comments are that if that is the way its supposed to work it is a fairly useless feature.

Misconception #2 - If you pin something other than a cloud app like the BBC home page and quit FF after reading an article, they expect FF to open that pinned tab in the BBC home page. Again this is a perception issue; however, there are a fair number of people who view this as a bug.

I have no way of quantifying how wide this is other than the folks on mozillazine. You may have a better handle on this using something like Test Pilot.


Reproducible: Always

Steps to Reproduce:
1. Go to the Gmail inbox and pin it
2. Click on the link to go to Gmail sent mail
3. Quit FF
4. Relaunch FF and the pinned Gmail tab will be at Gmail sent mail



Expected Results:  
People rightly or wrongly expect the pinned tab to go to the original page (in this example Gmail inbox).

This feature needs to be better explained or modified to line up with user perceptions.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Version: unspecified → 4.0 Branch
Duplicate of bug: 645549
You need to log in before you can comment on or make changes to this bug.