checksetup.pl - some ppm installed failed: Can't find any package

RESOLVED INVALID

Status

()

Bugzilla
Installation & Upgrading
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: meghyx, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.30; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.2; .NET4.0C; OfficeLiveConnector.1.3; OfficeLivePatch.0.0)
Build Identifier: 4.0

I am in the process to upgrade the Bugzilla from 3.6.2 to 4.0. When I ran the checksetup.pl, I got this result:
D:\Bugzilla>checksetup.pl
* This is Bugzilla 4.0 on perl 5.10.0
* Running on Win2003 Build 3790 (Service Pack 2)

Checking perl modules...
Checking for               CGI.pm (v3.51)     ok: found v3.52
Checking for           Digest-SHA (any)       ok: found v5.47
Checking for             TimeDate (v2.21)     ok: found v2.22
Checking for             DateTime (v0.28)     ok: found v0.61
Checking for    DateTime-TimeZone (v0.79)     ok: found v1.20
Checking for                  DBI (v1.41)     ok: found v1.607
Checking for     Template-Toolkit (v2.22)     ok: found v2.22
Checking for           Email-Send (v2.16)     ok: found v2.198
Checking for           Email-MIME (v1.904)    found v1.903
Checking for                  URI (any)       ok: found v1.37
Checking for       List-MoreUtils (v0.22)     ok: found v0.22

Checking available perl DBD modules...
Checking for               DBD-Pg (v1.45)     not found
Checking for            DBD-mysql (v4.00)     ok: found v4.011
Checking for           DBD-Oracle (v1.19)     ok: found v1.21

The following Perl modules are optional:
Checking for                   GD (v1.20)     ok: found v2.41
Checking for                Chart (v2.1)      ok: found v2.4.1
Checking for          Template-GD (any)       ok: found v1.56
Checking for           GDTextUtil (any)       ok: found v0.86
Checking for              GDGraph (any)       ok: found v1.44
Checking for             XML-Twig (any)       ok: found v3.34
Checking for           MIME-tools (v5.406)    ok: found v5.428
Checking for          libwww-perl (any)       ok: found v5.814
Checking for          PatchReader (v0.9.4)    ok: found v0.9.5
Checking for            perl-ldap (any)       ok: found v0.4001
Checking for          Authen-SASL (any)       ok: found v2.15
Checking for           RadiusPerl (any)       ok: found v0.17
Checking for            SOAP-Lite (v0.712)    not found
Checking for             JSON-RPC (any)       ok: found v0.96
Checking for              JSON-XS (v2.0)      ok: found v2.2222
Use of uninitialized value in open at C:/Perl/site/lib/Test/Taint.pm line 334, <
DATA> line 522.
Checking for           Test-Taint (any)       ok: found v1.04
Checking for          HTML-Parser (v3.40)     ok: found v3.56
Checking for        HTML-Scrubber (any)       ok: found v0.08
Checking for Email-MIME-Attachment-Stripper (any)       ok: found v1.316
Checking for          Email-Reply (any)       ok: found v1.202
Checking for          TheSchwartz (any)       not found
Checking for       Daemon-Generic (any)       not found
Checking for             mod_perl (v1.999022) ok: found v2.000004
Checking for     Apache-SizeLimit (v0.93)     not found
Checking for   Math-Random-Secure (v0.05)     ok: found v0.06
Checking for            Win32-API (any)       ok: found v0.55
***********************************************************************
* REQUIRED MODULES                                                    *
***********************************************************************
* Bugzilla requires you to install some Perl modules which are either *
* missing from your system, or the version on your system is too old. *
* See below for commands to install these modules.                    *
***********************************************************************
* OPTIONAL MODULES                                                    *
***********************************************************************
* Certain Perl modules are not required by Bugzilla, but by           *
* installing the latest version you gain access to additional         *
* features.                                                           *
*                                                                     *
* The optional modules you do not have installed are listed below,    *
* with the name of the feature they enable. Below that table are the  *
* commands to install each module.                                    *
***********************************************************************
*      MODULE NAME * ENABLES FEATURE(S)                               *
***********************************************************************
*        SOAP-Lite * XML-RPC Interface                                *
*      TheSchwartz * Mail Queueing                                    *
*   Daemon-Generic * Mail Queueing                                    *
* Apache-SizeLimit * mod_perl                                         *
***********************************************************************
* Note For Windows Users                                              *
***********************************************************************
* In order to install the modules listed below, you first have to run *
* the following command as an Administrator:                          *
*                                                                     *
*   ppm repo add theory58S http://cpan.uwinnipeg.ca/PPMPackages/10xx/
***********************************************************************
COMMANDS TO INSTALL OPTIONAL MODULES:

      SOAP-Lite: ppm install SOAP-Lite
    TheSchwartz: ppm install TheSchwartz
 Daemon-Generic: ppm install Daemon-Generic
Apache-SizeLimit: ppm install Apache-SizeLimit

COMMANDS TO INSTALL REQUIRED MODULES (You *must* run all these commands
and then re-run this script):

    ppm install Email-MIME
*** Installation aborted. Read the messages above. ***


So I ran the command
   ppm repo add theory58S http://cpan.uwinnipeg.ca/PPMPackages/10xx/

I got this result:
  ppm repo failed: Repo theory58S already set up with URL   http://cpan.uwinnipeg.ca/PPMPackages/10xx/


Then I tried the following commands, and also getting error results:

ppm install SOAP-Lite
ppm install failed: Can't find any package that provides Apache:: for SOAP-Lite
 
ppm install Apache-SizeLimit
ppm install failed: Can't find any package that provides mod_perl:: for Apache-SizeLimit

ppm install Daemon-Generic
ppm install failed: Can't find any package that provides Daemon-Generic

ppm install TheSchwartz
ppm install failed: Can't find any package that provides TheSchwartz

ppm install Email-MIME
No missing packages to install

 

I ran checksetup.pl again, and got the exactly same thing from the first time. 

 
Any idea how to fix the issue?



Reproducible: Always

Comment 1

7 years ago
Hi! I'm sorry you're having this problem. This actually isn't a bug in Bugzilla, which means that filing it here won't get you the assistance that you want. The best place to ask this question would be the support-bugzilla mailing list, described here:

  http://www.bugzilla.org/support/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.